games-engines/love: Stop using games.eclass
authorPacho Ramos <pacho@gentoo.org>
Sun, 22 Apr 2018 19:33:42 +0000 (21:33 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 22 Apr 2018 19:40:03 +0000 (21:40 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

games-engines/love/love-0.7.2-r2.ebuild [new file with mode: 0644]

diff --git a/games-engines/love/love-0.7.2-r2.ebuild b/games-engines/love/love-0.7.2-r2.ebuild
new file mode 100644 (file)
index 0000000..e29f78d
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A framework for 2D games in Lua"
+HOMEPAGE="http://love2d.org/"
+SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0.7"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-games/physfs
+       dev-lang/lua:0[deprecated]
+       media-libs/devil[mng,png,tiff]
+       media-libs/freetype:2
+       media-libs/libmodplug
+       media-libs/libsdl[joystick,opengl]
+       media-libs/libvorbis
+       media-libs/openal
+       media-sound/mpg123
+       virtual/opengl
+"
+DEPEND="${RDEPEND}
+       media-libs/libmng:0
+       media-libs/tiff:0
+"
+
+S="${WORKDIR}/${PN}-HEAD"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.8.0-freetype2.patch )
+
+src_install() {
+       DOCS="readme.txt changes.txt" \
+               default
+
+       mv "${ED}/usr/bin/${PN}" "${ED}/usr/bin/${PN}-${SLOT}" || die
+}