dev-python/aiodns: use correct typing distribution
authorGerion Entrup <gerion.entrup@flump.de>
Thu, 17 Oct 2019 12:09:24 +0000 (14:09 +0200)
committerZac Medico <zmedico@gentoo.org>
Fri, 18 Oct 2019 06:40:31 +0000 (23:40 -0700)
With the Gentoo startfiles for Python the typing distribution for
Python 3.6  and Python 3.7 is searched as external library and not as
part of the standard library.

Backport fix from https://github.com/saghul/aiodns/commit/281112107c742a3e24e8bce2cb09c3c4d9d01b6d

Closes: https://github.com/gentoo/gentoo/pull/13324
Closes: https://bugs.gentoo.org/692720
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
Signed-off-by: Zac Medico <zmedico@gentoo.org>
dev-python/aiodns/aiodns-2.0.0-r1.ebuild [moved from dev-python/aiodns/aiodns-2.0.0.ebuild with 75% similarity]

similarity index 75%
rename from dev-python/aiodns/aiodns-2.0.0.ebuild
rename to dev-python/aiodns/aiodns-2.0.0-r1.ebuild
index 7763f5b57eb960a2130795bb28855dead25b1ea2..0799c11f85d1709cde61b4b2f548b6dfc4ee6d13 100644 (file)
@@ -21,6 +21,13 @@ RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]"
 
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+
+       #692720 apply https://github.com/saghul/aiodns/pull/73
+       sed -e 's|typing; python_version<"3.7"|typing; python_version<"3.5"|' -i setup.py || die
+}
+
 python_test() {
        "${EPYTHON}" tests.py -v || die
 }