dev-perl/Template-Plugin-Cycle: Add build fix for Perl 5.26, bug 623130
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 3 Jul 2017 22:38:06 +0000 (00:38 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 3 Jul 2017 22:38:06 +0000 (00:38 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild

index fe309be714983506fc3d297a932d94a5c3421335..3252874f10fad44ff1a7eb17697d0dbe09feeba3 100644 (file)
@@ -1,19 +1,27 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
-MODULE_AUTHOR="ADAMK"
-MODULE_VERSION="1.06"
+DIST_AUTHOR="ADAMK"
+DIST_VERSION="1.06"
 
 inherit perl-module
 
 DESCRIPTION="Cyclically insert into a Template from a sequence of values"
 
-LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
 SLOT="0"
 KEYWORDS="~amd64"
 IUSE=""
 
-DEPEND=">=dev-perl/Params-Util-1.60.0
-       >=dev-perl/Template-Toolkit-2.240.0"
+RDEPEND="
+       >=dev-perl/Params-Util-1.60.0
+       >=dev-perl/Template-Toolkit-2.240.0
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}