dev-cpp/catch: Bump to 2.1.0
authorMichał Górny <mgorny@gentoo.org>
Fri, 12 Jan 2018 08:51:10 +0000 (09:51 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 12 Jan 2018 09:24:13 +0000 (10:24 +0100)
dev-cpp/catch/Manifest
dev-cpp/catch/catch-2.1.0.ebuild [new file with mode: 0644]

index 07e4ff02ba7e7de5b53a1eabd88ae6dd403127f8..b0895584ad76072dbd5b15124b258c9e5ea1a85b 100644 (file)
@@ -1,2 +1,3 @@
 DIST Catch-1.11.0.tar.gz 376132 BLAKE2B 23a1a6292dd91ec1c71923b4902b42b59ff6be5227b666f68ef0dc33756a58a63edd70a9b139dda0b1860c2b7a0cfec7ab9262e6447eff3184cfe28ea9b0aa77 SHA512 33085c2671f78c7562eace909564b2730eabcaf4490cd463402e66ab4ac2be1fe4fe360916c11aa589ba4a010622444126ee2ae747783b5869b5d7276361f132
 DIST Catch2-2.0.1.tar.gz 397154 BLAKE2B e41cb3afb706ebed5742b2639cbba9a3468b6325788c6928f8c4e307cd0b11a5fda6aa91def709536ec56412010c0865589999f1cb270630372ba3275bd36fbf SHA512 df6dc480aa208c6c39c8b36d06295883345f925b7ec579e9f0f7a68c816b90dbc3c2ece32926a6458646f7412027212f1b4c3cb28f217f411d3a56580f6edc32
+DIST Catch2-2.1.0.tar.gz 475638 BLAKE2B 66c48b7fe551f066e43870465e0fb58b966243d00cfe78c22389af45cf1cf97d6b3c192cdbf6aec4046ff3744a03e0125ca3b66f7c2a47d17f5a6ce538ad8959 SHA512 1fa0d1cb607fcb8dec37437fa788868324b0ded8e929138f4167d57bafa567b64955546142699a3e3bd2aeb7d36b7c2c7c426aaf3d68b94bddd43b2f78026fc8
diff --git a/dev-cpp/catch/catch-2.1.0.ebuild b/dev-cpp/catch/catch-2.1.0.ebuild
new file mode 100644 (file)
index 0000000..ac2dfcb
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_P=${PN^}2-${PV}
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+       local mycmakeargs=(
+               -DNO_SELFTEST=$(usex !test)
+       )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+       dodoc -r docs/.
+}