app-arch/bzip2: add landmine to ensure SLOT gets updated
authorMike Gilbert <floppym@gentoo.org>
Sat, 11 Apr 2020 17:25:24 +0000 (13:25 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sat, 11 Apr 2020 17:26:03 +0000 (13:26 -0400)
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
app-arch/bzip2/bzip2-1.0.8-r1.ebuild
app-arch/bzip2/bzip2-9999.ebuild

index e1e25b90ee47cf8f6220b5111ffe3594c1cedcf5..f9c097a85a47a521dd14846f70b831177c0c6090 100644 (file)
@@ -17,6 +17,12 @@ SLOT="0/1" # subslot = SONAME
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
 IUSE="static static-libs"
 
+if [[ ${PV} == 1.1* ]]; then
+    eerror "Please update SLOT due to accidental soname change in bzip2-1.0.7."
+    eerror "See commit 98da0ad82192d21ad74ae52366ea8466e2acea24 for reference."
+    die "SLOT update needed"
+fi
+
 PATCHES=(
        "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
        "${FILESDIR}"/${PN}-1.0.8-saneso.patch
index a0c9cd7a462f729055b2cb52565ea5f1e01884cc..266dd9856aac2f452b4cc6e36de70cebb8dbe66d 100644 (file)
@@ -16,9 +16,14 @@ else
 fi
 LICENSE="BZIP2"
 SLOT="0/1" # subslot = SONAME
-
 IUSE="static-libs"
 
+if [[ ${PV} == 1.1* ]]; then
+       eerror "Please update SLOT due to accidental soname change in bzip2-1.0.7."
+       eerror "See commit 98da0ad82192d21ad74ae52366ea8466e2acea24 for reference."
+       die "SLOT update needed"
+fi
+
 multilib_src_configure() {
        local emesonargs=(
                -Ddefault_library=$(usex static-libs both shared)