dev-python/flufl-i18n: Bump and Python 3.7.
authorHanno Böck <hanno@gentoo.org>
Fri, 7 Feb 2020 08:37:47 +0000 (09:37 +0100)
committerHanno Böck <hanno@gentoo.org>
Fri, 7 Feb 2020 08:37:47 +0000 (09:37 +0100)
Bug: https://bugs.gentoo.org/705332
Signed-off-by: Hanno Böck <hanno@gentoo.org>
Package-Manager: Portage-2.3.87, Repoman-2.3.20

dev-python/flufl-i18n/Manifest
dev-python/flufl-i18n/flufl-i18n-2.0.2.ebuild [new file with mode: 0644]

index 8a9fafda9813937f918dd88347522a1b897bd8b1..8ab39e236a95de5f6b5a876139094d6e1f2b53d9 100644 (file)
@@ -1 +1,2 @@
 DIST flufl-i18n-2.0.1.tar.gz 18572 BLAKE2B 372240eb6cf3778844fc0d5b59a60e2fd50498969165a6ea1096e1e333a536b177cbd9afbad14bfafc2cf7150923c8bdf0c84944d1426f0ae284028b406559e1 SHA512 372a27c81c0c58994b7b4b9ddb177f6acd3106536391c82c61cf1ba1b8b2e920be559720d98046ee9aa977a9119f231f7bbe71535cfb538d8563fff1da737ee1
+DIST flufl-i18n-2.0.2.tar.gz 19106 BLAKE2B 407f69708234e4c24403733c752ed79dfc0ff7d269a325c2d599ac00a0de077dfe63078fd050556f683008296885f397a59ea42b6d0692549856535166e63805 SHA512 05d9283bed456ee8d48704dc595f514e13b0c74096df177ed49bf178987baeee014ddc4331cc7d36edffbee1dcb58fcae152c2cb317b7ce73d9630864b98f1cd
diff --git a/dev-python/flufl-i18n/flufl-i18n-2.0.2.ebuild b/dev-python/flufl-i18n/flufl-i18n-2.0.2.ebuild
new file mode 100644 (file)
index 0000000..e583ee1
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="A high level API for Python internationalization."
+HOMEPAGE="https://gitlab.com/warsaw/flufl.i18n"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"