x11-libs/gtk+: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 12:19:18 +0000 (14:19 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 12:20:03 +0000 (14:20 +0200)
Package-Manager: portage-2.2.20.1

x11-libs/gtk+/Manifest
x11-libs/gtk+/gtk+-3.16.6.ebuild [new file with mode: 0644]

index c59b726b84eda27d2fdd98952fb1e40a14b2e6c6..3337258f21a507d636033e3718de23d87c33598d 100644 (file)
@@ -8,3 +8,4 @@ DIST gtk+-3.14.13.tar.xz 15784112 SHA256 b1efcb1ef299f9b205e6f4512428315fd03484e
 DIST gtk+-3.14.9.tar.xz 15716588 SHA256 3be9560e6e99388d7706a168e3353ecd63fc30ec4f7f8bea23889e71ab7b6c64 SHA512 3b64142d65ec4b4e0ed709c2fac629d80b95dac03481a3d6f8e3cc6c351ac779fe172a1edee552df7b3c40287f10c97fa0e99212e5f0e6b4751e3d8efd0896e5 WHIRLPOOL bc45b3722913ebb90bff944ec724909d01e3e976d49f8bd273500de2af9de7dcedc85e24fca36226816993a10cb87f4477f4498cc67946449855b37a0790a2fa
 DIST gtk+-3.16.4.tar.xz 18235768 SHA256 1ee5dbd7a4cb81a91eaa1b7ae64ba5a3eab6a3c0a764155583ab96524590fc8e SHA512 02a021e9911054ad03adef943b0faae478903a9e1d10a584009ee84364ecdb541a27533ba11ed980bc2a6f39833490c180514efc2ca3669f7c5dc4a388f3f53d WHIRLPOOL 954c19f5478cac7b72aa3153a5fa7a876b0248d3f0cb0df02dfdc4c96d16975893e03c32988fbb2b46731a1661c4fa54fb1fc9e8a125621287eb739a3c47468b
 DIST gtk+-3.16.5.tar.xz 18263356 SHA256 b87c99d127eb962fc857c246b77a65322cdffd7dcbcf46a83bce2040e0f4bc31 SHA512 f8dd318d5d72e8c59534bf49e505de3575f7519d57398030f4c47a576c3b37e4f00fec1b5a3ba2a3769e94373504dfb6ca24b1015f1e8f8f7dca6f46114b95f8 WHIRLPOOL 9c7ca6a76bde91912043ccfb26375327628fb2206b0e613116c9b6b1f1d078cccf075690b7749d76e8ddea3e3118ecae79e49be98490db29a7a2042f843d0b97
+DIST gtk+-3.16.6.tar.xz 18273872 SHA256 4d12726d0856a968b41802ae5c5971d7e9bac532717e309d3f81b9989da5ffbe SHA512 0b3417c57ef755c8eb498b6800cd9e1dc1df01d508425c968944aaa0d7ff50f25a00370f9a6ccf23a87cc9f7fb251447e63055149264b997ee5a681e98dc54ec WHIRLPOOL f944cce4396d2519d357ef75f1e9d420b64d77004110f0e7d2eb643ae5b3f8182db5be28e35269a57ecfe9cbc3280dc65008c30ce1c977d64d0fbb317e6f6bce
diff --git a/x11-libs/gtk+/gtk+-3.16.6.ebuild b/x11-libs/gtk+/gtk+-3.16.6.ebuild
new file mode 100644 (file)
index 0000000..58ee8d5
--- /dev/null
@@ -0,0 +1,249 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils flag-o-matic gnome2 multilib virtualx multilib-minimal
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="3"
+IUSE="aqua broadway cloudprint colord cups examples +introspection test vim-syntax wayland X xinerama"
+REQUIRED_USE="
+       || ( aqua wayland X )
+       xinerama? ( X )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# FIXME: introspection data is built against system installation of gtk+:3
+# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
+COMMON_DEPEND="
+       >=dev-libs/atk-2.15[introspection?,${MULTILIB_USEDEP}]
+       >=dev-libs/glib-2.43.4:2[${MULTILIB_USEDEP}]
+       media-libs/fontconfig[${MULTILIB_USEDEP}]
+       >=media-libs/libepoxy-1.0[${MULTILIB_USEDEP}]
+       >=x11-libs/cairo-1.14[aqua?,glib,svg,X?,${MULTILIB_USEDEP}]
+       >=x11-libs/gdk-pixbuf-2.30:2[introspection?,X?,${MULTILIB_USEDEP}]
+       >=x11-libs/pango-1.36.7[introspection?,${MULTILIB_USEDEP}]
+       x11-misc/shared-mime-info
+
+       cloudprint? (
+               >=net-libs/rest-0.7[${MULTILIB_USEDEP}]
+               >=dev-libs/json-glib-1.0[${MULTILIB_USEDEP}] )
+       colord? ( >=x11-misc/colord-0.1.9:0=[${MULTILIB_USEDEP}] )
+       cups? ( >=net-print/cups-1.2[${MULTILIB_USEDEP}] )
+       introspection? ( >=dev-libs/gobject-introspection-1.39:= )
+       wayland? (
+               >=dev-libs/wayland-1.5.91[${MULTILIB_USEDEP}]
+               media-libs/mesa[wayland,${MULTILIB_USEDEP}]
+               >=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
+       )
+       X? (
+               >=app-accessibility/at-spi2-atk-2.5.3[${MULTILIB_USEDEP}]
+               x11-libs/libXrender[${MULTILIB_USEDEP}]
+               x11-libs/libX11[${MULTILIB_USEDEP}]
+               >=x11-libs/libXi-1.3[${MULTILIB_USEDEP}]
+               x11-libs/libXext[${MULTILIB_USEDEP}]
+               >=x11-libs/libXrandr-1.3[${MULTILIB_USEDEP}]
+               x11-libs/libXcursor[${MULTILIB_USEDEP}]
+               x11-libs/libXfixes[${MULTILIB_USEDEP}]
+               x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+               x11-libs/libXdamage[${MULTILIB_USEDEP}]
+               xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
+       )
+"
+DEPEND="${COMMON_DEPEND}
+       app-text/docbook-xsl-stylesheets
+       app-text/docbook-xml-dtd:4.1.2
+       dev-libs/libxslt
+       dev-libs/gobject-introspection-common
+       >=dev-util/gdbus-codegen-2.38.2
+       >=dev-util/gtk-doc-am-1.20
+       >=sys-devel/gettext-0.18.3[${MULTILIB_USEDEP}]
+       virtual/pkgconfig[${MULTILIB_USEDEP}]
+       X? (
+               x11-proto/xextproto[${MULTILIB_USEDEP}]
+               x11-proto/xproto[${MULTILIB_USEDEP}]
+               x11-proto/inputproto[${MULTILIB_USEDEP}]
+               x11-proto/damageproto[${MULTILIB_USEDEP}]
+               xinerama? ( x11-proto/xineramaproto[${MULTILIB_USEDEP}] )
+       )
+       test? (
+               media-fonts/font-misc-misc
+               media-fonts/font-cursor-misc )
+       examples? ( media-libs/libcanberra[gtk3] )
+"
+# gtk+-3.2.2 breaks Alt key handling in <=x11-libs/vte-0.30.1:2.90
+# gtk+-3.3.18 breaks scrolling in <=x11-libs/vte-0.31.0:2.90
+# >=xorg-server-1.11.4 needed for
+#  https://mail.gnome.org/archives/desktop-devel-list/2012-March/msg00024.html
+RDEPEND="${COMMON_DEPEND}
+       >=dev-util/gtk-update-icon-cache-3
+       !<gnome-base/gail-1000
+       !<x11-libs/vte-0.31.0:2.90
+       >=x11-themes/adwaita-icon-theme-3.14
+       X? ( !<x11-base/xorg-server-1.11.4 )
+       abi_x86_32? (
+               !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+               !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+       )
+"
+# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
+PDEPEND="
+       gnome-base/librsvg[${MULTILIB_USEDEP}]
+       vim-syntax? ( app-vim/gtk-syntax )
+"
+
+MULTILIB_CHOST_TOOLS=(
+       /usr/bin/gtk-query-immodules-3.0
+)
+
+strip_builddir() {
+       local rule=$1
+       shift
+       local directory=$1
+       shift
+       sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
+               || die "Could not strip director ${directory} from build."
+}
+
+src_prepare() {
+       # -O3 and company cause random crashes in applications. Bug #133469
+       replace-flags -O3 -O2
+       strip-flags
+
+       if ! use test ; then
+               # don't waste time building tests
+               strip_builddir SRC_SUBDIRS testsuite Makefile.{am,in}
+
+               # the tests dir needs to be build now because since commit
+               # 7ff3c6df80185e165e3bf6aa31bd014d1f8bf224 tests/gtkgears.o needs to be there
+               # strip_builddir SRC_SUBDIRS tests Makefile.{am,in}
+       fi
+
+       if ! use examples; then
+               # don't waste time building demos
+               strip_builddir SRC_SUBDIRS demos Makefile.{am,in}
+               strip_builddir SRC_SUBDIRS examples Makefile.{am,in}
+       fi
+
+       # gtk-update-icon-cache is installed by dev-util/gtk-update-icon-cache 
+       epatch "${FILESDIR}"/${PN}-3.16.2-remove_update-icon-cache.patch
+
+       epatch_user
+
+       eautoreconf
+       gnome2_src_prepare
+}
+
+multilib_src_configure() {
+       # need libdir here to avoid a double slash in a path that libtool doesn't
+       # grok so well during install (// between $EPREFIX and usr ...)
+       ECONF_SOURCE=${S} \
+       gnome2_src_configure \
+               $(use_enable aqua quartz-backend) \
+               $(use_enable broadway broadway-backend) \
+               $(use_enable cloudprint) \
+               $(use_enable colord) \
+               $(use_enable cups cups auto) \
+               $(multilib_native_use_enable introspection) \
+               $(use_enable wayland wayland-backend) \
+               $(use_enable X x11-backend) \
+               $(use_enable X xcomposite) \
+               $(use_enable X xdamage) \
+               $(use_enable X xfixes) \
+               $(use_enable X xkb) \
+               $(use_enable X xrandr) \
+               $(use_enable xinerama) \
+               --disable-papi \
+               --disable-mir-backend \
+               --enable-man \
+               --with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
+               --libdir="${EPREFIX}"/usr/$(get_libdir) \
+               CUPS_CONFIG="${EPREFIX}/usr/bin/${CHOST}-cups-config"
+
+       # work-around gtk-doc out-of-source brokedness
+       if multilib_is_native_abi; then
+               local d
+               for d in gdk gtk libgail-util; do
+                       ln -s "${S}"/docs/reference/${d}/html docs/reference/${d}/html || die
+               done
+       fi
+}
+
+multilib_src_test() {
+       # FIXME: this should be handled at eclass level
+       "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
+
+       unset DBUS_SESSION_BUS_ADDRESS
+       unset DISPLAY #527682
+       GSETTINGS_SCHEMA_DIR="${S}/gtk" Xemake check
+}
+
+multilib_src_install() {
+       gnome2_src_install
+
+       # add -framework Carbon to the .pc files, bug #???
+       if use aqua ; then
+               for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
+                       sed -e "s:Libs\: :Libs\: -framework Carbon :" \
+                               -i "${ED%/}"/usr/$(get_libdir)/pkgconfig/$i || die "sed failed"
+               done
+       fi
+}
+
+multilib_src_install_all() {
+       insinto /etc/gtk-3.0
+       doins "${FILESDIR}"/settings.ini
+
+       dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+}
+
+pkg_preinst() {
+       gnome2_pkg_preinst
+
+       multilib_pkg_preinst() {
+               # Make immodules.cache belongs to gtk+ alone
+               local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
+
+               if [[ -e ${EROOT}${cache} ]]; then
+                       cp "${EROOT}"${cache} "${ED}"/${cache} || die
+               else
+                       touch "${ED}"/${cache} || die
+               fi
+       }
+       multilib_parallel_foreach_abi multilib_pkg_preinst
+}
+
+pkg_postinst() {
+       gnome2_pkg_postinst
+
+       multilib_pkg_postinst() {
+               gnome2_query_immodules_gtk3 \
+                       || die "Update immodules cache failed (for ${ABI})"
+       }
+       multilib_parallel_foreach_abi multilib_pkg_postinst
+
+       if ! has_version "app-text/evince"; then
+               elog "Please install app-text/evince for print preview functionality."
+               elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+               elog "add it to your settings.ini file."
+       fi
+}
+
+pkg_postrm() {
+       gnome2_pkg_postrm
+
+       if [[ -z ${REPLACED_BY_VERSIONS} ]]; then
+               multilib_pkg_postrm() {
+                       rm -f "${EROOT}"usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache
+               }
+               multilib_foreach_abi multilib_pkg_postrm
+       fi
+}