net-misc/connman-gtk: do not call econf twice
authorMarek Szuba <marecki@gentoo.org>
Fri, 7 Jun 2019 11:44:16 +0000 (12:44 +0100)
committerMarek Szuba <marecki@gentoo.org>
Fri, 7 Jun 2019 11:45:33 +0000 (12:45 +0100)
Also, bump to EAPI-7.

Closes: https://bugs.gentoo.org/687550
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

net-misc/connman-gtk/connman-gtk-1.1.1-r1.ebuild [new file with mode: 0644]

diff --git a/net-misc/connman-gtk/connman-gtk-1.1.1-r1.ebuild b/net-misc/connman-gtk/connman-gtk-1.1.1-r1.ebuild
new file mode 100644 (file)
index 0000000..3888b84
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools gnome2-utils
+
+DESCRIPTION="GTK GUI for Connman"
+HOMEPAGE="https://github.com/jgke/connman-gtk"
+SRC_URI="https://github.com/jgke/connman-gtk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openconnect"
+
+CDEPEND="
+       >=dev-libs/glib-2.0:2
+       >=x11-libs/gtk+-3.10:3
+       openconnect? ( >=net-vpn/openconnect-5.99 )
+"
+RDEPEND="${CDEPEND}
+       net-misc/connman
+"
+DEPEND="${CDEOEND}
+       >=dev-util/intltool-0.35.0
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       default
+       sed -i -e '/^Categories/ s/$/;/' connman-gtk.desktop.in || die
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --disable-schemas-compile \
+               $(use_with openconnect)
+}
+
+pkg_preinst() {
+       gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       gnome2_schemas_update
+}