net-mail/mailutils: Fix building with GCC 10
authorDavid Seifert <soap@gentoo.org>
Sun, 23 Feb 2020 14:09:21 +0000 (15:09 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 23 Feb 2020 14:09:21 +0000 (15:09 +0100)
Bug: https://bugs.gentoo.org/709274
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
net-mail/mailutils/files/mailutils-3.4-fno-common.patch [new file with mode: 0644]
net-mail/mailutils/files/mailutils-3.8-fno-common.patch [new file with mode: 0644]
net-mail/mailutils/mailutils-3.4-r3.ebuild
net-mail/mailutils/mailutils-3.7.ebuild
net-mail/mailutils/mailutils-3.8.ebuild

diff --git a/net-mail/mailutils/files/mailutils-3.4-fno-common.patch b/net-mail/mailutils/files/mailutils-3.4-fno-common.patch
new file mode 100644 (file)
index 0000000..d981ae6
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/lib/tcpwrap.h
++++ b/lib/tcpwrap.h
+@@ -18,7 +18,7 @@
+ #include <mailutils/types.h>
+ extern int mu_tcp_wrapper_enable;
+-const char *mu_tcp_wrapper_daemon;
++extern const char *mu_tcp_wrapper_daemon;
+ extern int mu_tcpwrapper_access (int fd);
+ extern void mu_tcpwrapper_cfg_init (void);
+ extern int mu_tcp_wrapper_prefork (int fd, 
diff --git a/net-mail/mailutils/files/mailutils-3.8-fno-common.patch b/net-mail/mailutils/files/mailutils-3.8-fno-common.patch
new file mode 100644 (file)
index 0000000..c7aa72d
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/imap4d/imap4d.h
++++ b/imap4d/imap4d.h
+@@ -229,8 +229,6 @@ extern struct mu_tls_config global_tls_conf;
+ extern int test_mode;
+ extern int silent_expunge;
+-int tls_available;
+-
+ /* Input functions */
+ extern mu_stream_t iostream;
+ extern int  io_untagged_response (int, const char *, ...) MU_PRINTFLIKE(2,3);
+--- a/lib/tcpwrap.h
++++ b/lib/tcpwrap.h
+@@ -17,7 +17,7 @@
+ #include <mailutils/types.h>
+ extern int mu_tcp_wrapper_enable;
+-const char *mu_tcp_wrapper_daemon;
++extern const char *mu_tcp_wrapper_daemon;
+ extern int mu_tcpwrapper_access (int fd);
+ extern void mu_tcpwrapper_cfg_init (void);
+ extern int mu_tcp_wrapper_prefork (int fd, 
index 509c103ba01610486f2017f7ea10d5d6362e7d80..c3edc69e67260e93d750a0a360b9cbf1cc007f85 100644 (file)
@@ -56,8 +56,10 @@ pkg_setup() {
 src_prepare() {
        # Disable bytecompilation of Python modules.
        echo "#!/bin/sh" > build-aux/py-compile
-       eapply "${FILESDIR}/${P}-MH-testsuite.patch" \
-               "${FILESDIR}/${P}-fix-endianness.patch"
+       eapply \
+               "${FILESDIR}"/${P}-MH-testsuite.patch \
+               "${FILESDIR}"/${P}-fix-endianness.patch \
+               "${FILESDIR}"/${PN}-3.4-fno-common.patch
        # add missing tests so that make check doesn't fail
        cp "${FILESDIR}"/{hdr,nohdr,twomsg,weed}.at "${S}"/readmsg/tests || die
        if use mysql; then
index f565cbc30a7b91ccc2e6382d503f5f1110af34b1..344b83bfb471c30f3efd0eafa66ac357f1e8bf2f 100644 (file)
@@ -51,8 +51,11 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
        servers? ( tcpd ldap )"
 
 DOCS=( ABOUT-NLS AUTHORS COPYING COPYING.LESSER ChangeLog INSTALL NEWS README THANKS TODO )
-PATCHES=( "${FILESDIR}/${PN}-3.5-add-include.patch" \
-       "${FILESDIR}/${PN}-3.6-underlinking.patch" )
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.5-add-include.patch
+       "${FILESDIR}"/${PN}-3.6-underlinking.patch
+       "${FILESDIR}"/${PN}-3.8-fno-common.patch
+)
 
 pkg_setup() {
        use python && python-single-r1_pkg_setup
index a0eac2746bf2af430ae18fe64d37c73ded1cd1d2..010b4f58138b9c88b5c4d2c0ca8e034779373415 100644 (file)
@@ -52,10 +52,11 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
 
 DOCS=( ABOUT-NLS AUTHORS COPYING COPYING.LESSER ChangeLog INSTALL NEWS README THANKS TODO )
 PATCHES=(
-       "${FILESDIR}/${PN}-3.5-add-include.patch" \
-       "${FILESDIR}/${PN}-3.6-underlinking.patch" \
-       "${FILESDIR}/${PN}-3.8-fix-tests.patch" \
-       )
+       "${FILESDIR}"/${PN}-3.5-add-include.patch
+       "${FILESDIR}"/${PN}-3.6-underlinking.patch
+       "${FILESDIR}"/${PN}-3.8-fix-tests.patch
+       "${FILESDIR}"/${PN}-3.8-fno-common.patch
+)
 
 pkg_setup() {
        use python && python-single-r1_pkg_setup