dev-python/pyjwt: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 18 Mar 2020 18:17:50 +0000 (19:17 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 18 Mar 2020 18:17:50 +0000 (19:17 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyjwt/Manifest
dev-python/pyjwt/pyjwt-1.5.3.ebuild [deleted file]
dev-python/pyjwt/pyjwt-1.7.1.ebuild [deleted file]

index efcfa057cb80c74d972a2e18fafd7dc9f9fdd0ed..83d65a7066a8de3f55eeae4674754b4ea4bf5f59 100644 (file)
@@ -1,2 +1 @@
-DIST PyJWT-1.5.3.tar.gz 73044 BLAKE2B ae2e3caec52ddd768d573e0398bbc355c6eedca238db9b1808ff1d723b9fdee0845cf119d78e561833fe770e5ec39000905cec43a5e96102865f60e204c72c22 SHA512 b25a9f6a04bd072020fcf00bb559b7560902adb79746fb880432c01fa356748238432f53f6b9a21db50ece3e59ed4c45ca3f48ecec0ca3c4095e6a739a5c150c
 DIST PyJWT-1.7.1.tar.gz 41979 BLAKE2B 5604b309838b2dfb2f95e18e291c43703954664aa8acb7439072f002c1c8a1e49ff2c21d907be77a4d2f86e695ec71970d550aad2541252ac85bd7133e300b28 SHA512 70cd38127b6848933992c8b88303725ef71bfb430ad42eb63247e549b0bdab2a194137349d43ab02a1c97212dbc89f447ee3f0c5403dd14632b8b4b6b9235fc4
diff --git a/dev-python/pyjwt/pyjwt-1.5.3.ebuild b/dev-python/pyjwt/pyjwt-1.5.3.ebuild
deleted file mode 100644 (file)
index 53b0440..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 eutils
-
-MY_PN="PyJWT"
-
-DESCRIPTION="JSON Web Token implementation in Python"
-HOMEPAGE="https://github.com/progrium/pyjwt https://pypi.org/project/PyJWT/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE=" MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/cryptography-1.4.0[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}"/${MY_PN}-${PV}
-
-python_prepare_all() {
-       find . -name '__pycache__' -prune -exec rm -rf {} \; || die "Cleaning __pycache__ failed"
-       find . -name '*.pyc' -exec rm -f {} \; || die "Cleaing *.pyc failed"
-
-       # enables coverage, we don't need that
-       rm setup.cfg || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       pytest -vv || die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
-       elog "Available optional features:"
-       optfeature "cryptography" dev-python/cryptography
-       optfeature "flake8" dev-python/flake8
-
-       ewarn "flake8 feature requires 'flake8-import-order' and 'pep8-naming', which are not in portage yet"
-}
diff --git a/dev-python/pyjwt/pyjwt-1.7.1.ebuild b/dev-python/pyjwt/pyjwt-1.7.1.ebuild
deleted file mode 100644 (file)
index a165aa1..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 eutils
-
-MY_PN="PyJWT"
-
-DESCRIPTION="JSON Web Token implementation in Python"
-HOMEPAGE="https://github.com/progrium/pyjwt https://pypi.org/project/PyJWT/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE=" MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/cryptography-1.4.0[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}"/${MY_PN}-${PV}
-
-python_prepare_all() {
-       find . -name '__pycache__' -prune -exec rm -rf {} \; || die "Cleaning __pycache__ failed"
-       find . -name '*.pyc' -exec rm -f {} \; || die "Cleaing *.pyc failed"
-
-       # enables coverage, we don't need that
-       rm setup.cfg || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       pytest -vv || die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
-       elog "Available optional features:"
-       optfeature "cryptography" dev-python/cryptography
-       optfeature "flake8" dev-python/flake8
-
-       ewarn "flake8 feature requires 'flake8-import-order' and 'pep8-naming', which are not in portage yet"
-}