net-wireless/wpa_supplicant: support USE="-smartcard -ap -wps"
authorBrian Norris <briannorris@chromium.org>
Tue, 11 Jun 2019 00:18:40 +0000 (17:18 -0700)
committerRick Farina <zerochaos@gentoo.org>
Tue, 11 Jun 2019 01:18:14 +0000 (21:18 -0400)
These are enabled in the defconfig and need to be forced off here.

Bug: https://bugs.gentoo.org/687838
Signed-off-by: Brian Norris <briannorris@chromium.org>
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
net-wireless/wpa_supplicant/wpa_supplicant-2.8-r1.ebuild

index 52bb737406898ccce70c1a9dc1b590a76c8e94c6..b1b3a219ec3fdad57fb0400527e6a133259a3cbe 100644 (file)
@@ -237,6 +237,8 @@ src_configure() {
 
        if use smartcard ; then
                Kconfig_style_config SMARTCARD
+       else
+               Kconfig_style_config SMARTCARD n
        fi
 
        if use tdls ; then
@@ -281,6 +283,8 @@ src_configure() {
                Kconfig_style_config WPS_UPNP
                # Near Field Communication
                Kconfig_style_config WPS_NFC
+       else
+               Kconfig_style_config WPS n
        fi
 
        # Wi-Fi Direct (WiDi)
@@ -292,6 +296,8 @@ src_configure() {
        # Access Point Mode
        if use ap ; then
                Kconfig_style_config AP
+       else
+               Kconfig_style_config AP n
        fi
 
        # Enable essentials for AP/P2P