net-print/cups-filters: Bump to version 1.21.5
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 6 Dec 2018 15:30:07 +0000 (16:30 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 6 Dec 2018 15:32:17 +0000 (16:32 +0100)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-print/cups-filters/Manifest
net-print/cups-filters/cups-filters-1.21.5.ebuild [new file with mode: 0644]

index 7fbb9926e42c134a4fa108f9246bfebe45905160..49d24154c7fafdcd8262f945bbe08f2001af9dac 100644 (file)
@@ -2,3 +2,4 @@ DIST cups-filters-1.17.9.tar.xz 1454068 BLAKE2B 7c4b1c1a017cbaaf5d413071195ce53e
 DIST cups-filters-1.20.4.tar.xz 1474700 BLAKE2B 70948565e4a2b35d0c3bc510e7c03d77ac1ed47ab16a22bc9f60a7293fe5b5b08fdb1e95dd7a32f4c99a18676e50c48a515a954d437283ce7011ab616804e235 SHA512 4001cefbee945c326e3c597869763286e8665dee098b9aff76340dd249ef3e615f2a8df5c8e802e388b91dfd06ba9e8313b27908ca89ca120f899060785a6f07
 DIST cups-filters-1.21.3.tar.xz 1474152 BLAKE2B 7e5193b6d6989675fa9567cb76b7f29f411b28e251ff9c6fd8fafec9c9c3d914f21d7e51eb562820954b3cee70974c5a55351eb08a1f231fe820513a2ce92644 SHA512 2b00023ac4177046e3ab3c5b563b7bd92bb49e57e645e6e67e7b9358d00919e2d4ca43ef5d57684523d97f1f1df5d1014fc0a3a895476ce285ccb3ed2e3bc758
 DIST cups-filters-1.21.4.tar.xz 1474564 BLAKE2B 10a9ac9133ebefe1e04f329d1ce3ad1a30c4c1922a31e9af10fa26b3d8401753e1f1b66ef4c2869d4a7329af440e6da8c883bc00fddf614af1716a9d9cb83f4f SHA512 6e1e20be0354ba96cf4222c05aadd4a2b3d033d730ff9b7489ba6a3b2b0e1a02ac80a1ebcf5e765b80e5baab2ae0c091c8abbdf159913b70592fb9ba0afd9a5b
+DIST cups-filters-1.21.5.tar.xz 1474388 BLAKE2B 8e21302256c6da033e09b9b43da03edbe9f7345ec50497501522da773fc698494a674e66457570d8f43c081afc2787cdfc55d738ffe3397bf5fdd307bbb9952f SHA512 41ed3364cb0a87e8b2b2482f3c8de90eba63538682ad3fa1079908beadec5e975d9eda151d822e93f62dcc32fe2a6189cc02b6b7691640fb00434efec35c0f7a
diff --git a/net-print/cups-filters/cups-filters-1.21.5.ebuild b/net-print/cups-filters/cups-filters-1.21.5.ebuild
new file mode 100644 (file)
index 0000000..bf15e18
--- /dev/null
@@ -0,0 +1,137 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+       inherit bzr autotools
+       EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+else
+       SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic ipp_autosetup jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+
+RDEPEND="
+       >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+       >=app-text/qpdf-8.1.0:=
+       dev-libs/glib:2
+       media-libs/fontconfig
+       media-libs/freetype:2
+       media-libs/lcms:2
+       >=net-print/cups-1.7.3
+       !<=net-print/cups-1.5.9999
+       sys-devel/bc
+       sys-libs/zlib
+       dbus? ( sys-apps/dbus )
+       foomatic? ( !net-print/foomatic-filters )
+       jpeg? ( virtual/jpeg:0 )
+       ldap? ( net-nds/openldap )
+       pclm? ( >=app-text/qpdf-8.1.0:= )
+       pdf? ( app-text/mupdf )
+       perl? ( dev-lang/perl:= )
+       png? ( media-libs/libpng:0= )
+       postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+       tiff? ( media-libs/tiff:0 )
+       zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+       dev-util/gdbus-codegen
+       test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+       default
+       [[ "${PV}" == "9999" ]] && eautoreconf
+
+       # Bug #626800
+       append-cxxflags -std=c++11
+}
+
+src_configure() {
+       local myeconfargs=(
+               --docdir="${EPREFIX}/usr/share/doc/${PF}"
+               --enable-imagefilters
+               --localstatedir="${EPREFIX}"/var
+               --with-browseremoteprotocols=DNSSD,CUPS
+               --with-cups-rundir="${EPREFIX}"/run/cups
+               --with-fontdir="fonts/conf.avail"
+               --with-pdftops=pdftops
+               --with-rcdir=no
+               --without-php
+               $(use_enable dbus)
+               $(use_enable foomatic)
+               $(use_enable ipp_autosetup auto-setup-driverless)
+               $(use_enable ldap)
+               $(use_enable pclm)
+               $(use_enable pdf mutool)
+               $(use_enable postscript ghostscript)
+               $(use_enable postscript ijs)
+               $(use_enable static-libs static)
+               $(use_enable zeroconf avahi)
+               $(use_with jpeg)
+               $(use_with png)
+               $(use_with tiff)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_configure
+               perl-module_src_compile
+               popd > /dev/null
+       fi
+}
+
+src_install() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_install
+               perl_delete_localpod
+               popd > /dev/null
+       fi
+
+       if use postscript; then
+               # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+               dosym gstoraster /usr/libexec/cups/filter/pstoraster
+               dosym gstopxl /usr/libexec/cups/filter/pstopxl
+       fi
+
+       find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+       cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+       if ! use zeroconf ; then
+               sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+               sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+       fi
+
+       doinitd "${T}"/cups-browsed
+       systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+src_test() {
+       emake check
+}
+
+pkg_postinst() {
+       if ! use foomatic ; then
+               ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+               ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+       fi
+}