dev-ml/cppo: Fix build with USE=-ocamlopt. Bug #624286
authorAlexis Ballier <aballier@gentoo.org>
Sun, 9 Jul 2017 08:28:03 +0000 (10:28 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sun, 9 Jul 2017 08:28:03 +0000 (10:28 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-ml/cppo/cppo-1.5.0.ebuild

index c9d5a1d7375c682e23c3ff7d0e5d0bbe0c576cba..edc62efc16d988eec5352795bf2be4109af53f9c 100644 (file)
@@ -22,7 +22,7 @@ DEPEND="${RDEPEND}"
 
 src_compile() {
        use ocamlopt || sed -e 's/ocamlbuild_cppo.cmx/ocamlbuild_cppo.cmo/' -i Makefile
-       emake BEST="$(usex ocamlopt '.native' '.byte')"
+       emake BEST="$(usex ocamlopt '.native' '.byte')" $(usex ocamlopt opt all) ocamlbuild
 }
 
 src_install() {