games-arcade/oshu: Fix tests
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>
Sat, 4 Apr 2020 07:10:35 +0000 (10:10 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Sat, 4 Apr 2020 07:38:57 +0000 (10:38 +0300)
Turn out it was failing because cmake.eclass calls ctest directly

Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
games-arcade/oshu/oshu-2.0.1.ebuild
games-arcade/oshu/oshu-9999.ebuild

index 84d415b3c11a1fcad366b84d4049555099f160a1..f394d808178922620bf56c64402aa7115dd9eeca 100644 (file)
@@ -32,10 +32,6 @@ RDEPEND="
 
 DEPEND="${RDEPEND}"
 
-# Doesn't build executable needed for the test
-# https://github.com/fmang/oshu/issues/87
-RESTRICT="test"
-
 src_prepare() {
        if use osu-skin; then
                eapply "${FILESDIR}/oshu-2.0.0-use_unpacked_osu-skin.patch"
@@ -53,3 +49,7 @@ src_configure() {
 
        cmake_src_configure
 }
+
+src_test() {
+       cmake_build check
+}
index 84d415b3c11a1fcad366b84d4049555099f160a1..f394d808178922620bf56c64402aa7115dd9eeca 100644 (file)
@@ -32,10 +32,6 @@ RDEPEND="
 
 DEPEND="${RDEPEND}"
 
-# Doesn't build executable needed for the test
-# https://github.com/fmang/oshu/issues/87
-RESTRICT="test"
-
 src_prepare() {
        if use osu-skin; then
                eapply "${FILESDIR}/oshu-2.0.0-use_unpacked_osu-skin.patch"
@@ -53,3 +49,7 @@ src_configure() {
 
        cmake_src_configure
 }
+
+src_test() {
+       cmake_build check
+}