media-libs/gst-rtsp-server: bump to 1.14.2 for upstream bug fixes
authorMart Raudsepp <leio@gentoo.org>
Tue, 31 Jul 2018 08:18:09 +0000 (11:18 +0300)
committerMart Raudsepp <leio@gentoo.org>
Tue, 31 Jul 2018 08:44:56 +0000 (11:44 +0300)
Package-Manager: Portage-2.3.43, Repoman-2.3.10

media-libs/gst-rtsp-server/Manifest
media-libs/gst-rtsp-server/gst-rtsp-server-1.14.2.ebuild [new file with mode: 0644]

index 4d2b61283d2520252607328b01e23b5e2e2aac64..866d9ceec687d8bcc34e044817f9401d4047a6d2 100644 (file)
@@ -1,2 +1,3 @@
 DIST gst-rtsp-0.10.8.tar.bz2 567670 BLAKE2B 10c01001a53daa039b1c48917fcd31ac0f6437d365bac2aa6b70d0b43cb94df89ab1d2a55b8fc89f5e04efffca142f99fe0f96a1c2708acc9a062f4f3a01cd8d SHA512 c5020cffa9334b7d9c6b9dbe6f32bd4580eeee1c67689269d232e954ef9d96d8b988e3fb19da89701eae26419df0bf6de5796f7780cfbedda4c07154b1c1ebd7
 DIST gst-rtsp-server-1.14.1.tar.xz 662316 BLAKE2B 9ff6abe945b1a4936a713e098a2013c0d954a1f7f0fdf4f9d9ec0df9ff19f5526c96a95c101ae58db97a886cb477c001eea1dc056bd4e35e4bcd4cdd16a4dfcb SHA512 c559177434cd710702be623da0e9821e3867f865c94bfc425e558a467288ff77ee1ce9114389d8f8462fd979eb34a8da665d40e8e0b10a54a077f53ec954d07a
+DIST gst-rtsp-server-1.14.2.tar.xz 665904 BLAKE2B 3f9ab3c1579d34ec8877bcc6da2802cc69aa444ef1fabfe548e2acf3b1c58eb0e29ffb09c250fb6d2ae61e4847bf2098c22874ec43266d46d5b402cbbbcda892 SHA512 81c64c31cef45479ec23d57b11d09950ca8c04820b6cf422af6caabccd71ad648e210a114f9f020136ddfdfc9e942c3eb15f055778d493d54c8770ed4f93634c
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.14.2.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.14.2.ebuild
new file mode 100644 (file)
index 0000000..6669657
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gstreamer
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-rtsp-server.html"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +introspection static-libs test"
+
+# gst-plugins-base for many used elements and API
+# gst-plugins-good for rtprtxsend and rtpbin elements, maybe more
+# gst-plugins-srtp for srtpenc and srtpdec elements
+RDEPEND="
+       >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+       >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+       >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+       >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+       >=media-plugins/gst-plugins-srtp-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+       introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+"
+DEPEND="${RDEPEND}
+       >=dev-util/gtk-doc-am-1.12
+"
+
+# Due to gstreamer src_configure
+QA_CONFIGURE_OPTIONS="--enable-nls"
+
+multilib_src_configure() {
+       # debug: only adds -g to CFLAGS
+       # docbook: nothing behind that switch
+       # libcgroup is automagic and only used in examples
+       gstreamer_multilib_src_configure \
+               --disable-debug \
+               --disable-valgrind \
+               --disable-examples \
+               --disable-docbook \
+               --disable-gtk-doc \
+               $(multilib_native_use_enable introspection) \
+               $(use_enable static-libs static) \
+               $(use_enable test tests) \
+               LIBCGROUP_LIBS= \
+               LIBCGROUP_FLAGS=
+
+       # work-around gtk-doc out-of-source brokedness
+       if multilib_is_native_abi ; then
+               ln -s "${S}"/docs/libs/${d}/html docs/libs/${d}/html || die
+       fi
+}
+
+multilib_src_install() {
+       emake install DESTDIR="${D}"
+       # Handle broken upstream modifications to defaults of gtk-doc
+       emake install -C docs/libs DESTDIR="${D}"
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       find "${ED}" -name '*.la' -delete || die
+
+       if use examples ; then
+               insinto /usr/share/doc/${PF}/examples
+               doins "${S}"/examples/*.c
+       fi
+}