dev-python/webtest: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 09:54:48 +0000 (10:54 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 13:39:16 +0000 (14:39 +0100)
dev-python/webtest/Manifest
dev-python/webtest/webtest-2.0.16.ebuild [deleted file]

index 4baca685fdb180738da392848616d142564202d6..cc3380a64e5fbb09c8ffcf176f9ad18d33c2d4fd 100644 (file)
@@ -1,2 +1 @@
-DIST WebTest-2.0.16.zip 88232 BLAKE2B 659ba614aae5fcd9194c7efc63c7d34096e66d6edf12efae569902caafd1f782a501a6c4ce1df0ebea3be61bd1674609e9be96860afdf0dc3ec667e0530837e7 SHA512 da09abba8ed52c8d673acf547f47df6919b534b33b746944610fc78bd3695f36e3718f89e68f8aec7852b6cf98da0f0b5500dfe9427fd7926e5304ad216eafbb
 DIST WebTest-2.0.21.tar.gz 66866 BLAKE2B d2830fcce7fb4b91029838806952e3e9c6916c3b292c7142138f30486d936b4a1f0c2d28a5973b0c351c64e499f343f3711296c6e37c38548e3a81b108163a17 SHA512 21f58ee9192fd0eb0eb2d88179ffc015aa5cf04c8004db251bd65d13d54c34b9e6b5fc9fdd8e9fcbbc18fcfb2be714c0691b2ef034318861262f8705b4a44610
diff --git a/dev-python/webtest/webtest-2.0.16.ebuild b/dev-python/webtest/webtest-2.0.16.ebuild
deleted file mode 100644 (file)
index fb9c40e..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-MY_PN="WebTest"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="http://pythonpaste.org/webtest/ https://pypi.python.org/pypi/WebTest"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc64 ~s390 ~sh sparc x86"
-IUSE="doc test"
-
-#nose<1.3.0
-RDEPEND="
-       dev-python/six[${PYTHON_USEDEP}]
-       >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
-       >=dev-python/webob-1.2[${PYTHON_USEDEP}]
-       dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
-       dev-python/lxml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       app-arch/unzip
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/pyquery[${PYTHON_USEDEP}]
-               dev-python/pastedeploy[${PYTHON_USEDEP}]
-               dev-python/wsgiproxy2[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 )
-       )"
-
-S="${WORKDIR}/${MY_P}"
-
-# Makes testing easier; otherwise we get errors from pkg_resources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
-       # Prevent un-needed d'loading during doc build
-       sed -s 's:intersphinx_mapping:_&:' -i docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs html || die
-       fi
-}
-
-python_test() {
-       # Tests raise ImportErrors with our default PYTHONPATH.
-       local -x PYTHONPATH=
-       nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( html/. )
-       distutils-r1_python_install_all
-}