dev-ruby/yard: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sun, 28 Jul 2019 15:29:06 +0000 (17:29 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 28 Jul 2019 15:29:06 +0000 (17:29 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/yard/Manifest
dev-ruby/yard/yard-0.9.11.ebuild [deleted file]

index c3ceb4f5e65ac9c1418c061c210dbd4bf7e1540c..5354ca18f4367cbb8e1532f67182f1ea5ca412a1 100644 (file)
@@ -1,2 +1 @@
-DIST yard-0.9.11-git.tgz 916355 BLAKE2B e9f27fe129cf93c51dbf83f4a7d5745d385252ba63c90f85223f2e9436c22a55aaba296f263072069d39e4beaca3e0830775a8be121c64cdc2a15afd3539a73f SHA512 375a4878e61888cf73aaa06e9300195ae48b9898d8cd639fa796a067e5fa0b89d6ef62d327a388ee83953e80177515f4d8c070042188e3a1e597f48b82b3a72e
 DIST yard-0.9.20-git.tgz 921130 BLAKE2B 37b1b2524147a1a8cb36c3835cce4e7666e2c8d3d5c187eb402000fb251df64111c4f104957ac9d28bd0e8d9328eb1d97571337ae54479626dcaab3cf07625a6 SHA512 b7e035a3598c8ef32fcbaae57254c0fb0cba875606b434571da2ef754f3171b5c42a4b3a45bd4bf41bce368f6fb7e448567f601a9cab5fbdae695bbec1b73608
diff --git a/dev-ruby/yard/yard-0.9.11.ebuild b/dev-ruby/yard/yard-0.9.11.ebuild
deleted file mode 100644 (file)
index 1837bcd..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_TASK_DOC="yard"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_DOCDIR="doc docs"
-
-RUBY_FAKEGEM_EXTRAINSTALL="templates"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Documentation generation tool for the Ruby programming language"
-HOMEPAGE="https://yardoc.org/"
-
-# The gem lakes the gemspec file needed to pass tests.
-SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/bluecloth dev-ruby/kramdown ) )"
-
-ruby_add_bdepend "test? ( >=dev-ruby/ruby-gettext-2.3.8 dev-ruby/rack )"
-
-all_ruby_prepare() {
-       sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
-
-       # Avoid specs that make assumptions on load ordering that are not
-       # true for us. This may be related to how we install in Gentoo. This
-       # also drops a test requirement on dev-ruby/rack.
-       rm -f spec/cli/server_spec.rb || die
-
-       # Avoid redcarpet-specific spec that is not optional
-       sed -i -e '/autolinks URLs/askip "make redcarpet optional"' spec/templates/helpers/html_helper_spec.rb || die
-}