dev-python/versioneer-0.18-r1: add Python 3.8
authorVictor Payno <vpayno+gentoo@gmail.com>
Sun, 12 Apr 2020 07:03:31 +0000 (00:03 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Sun, 26 Apr 2020 03:11:48 +0000 (20:11 -0700)
Signed-off-by: Victor Payno <vpayno+gentoo@gmail.com>
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/versioneer/files/versioneer-0.18-fix_test_git.patch [new file with mode: 0644]
dev-python/versioneer/versioneer-0.18-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/versioneer/files/versioneer-0.18-fix_test_git.patch b/dev-python/versioneer/files/versioneer-0.18-fix_test_git.patch
new file mode 100644 (file)
index 0000000..35c4597
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/test/git/test_git.py     2020-04-11 23:36:18.858361255 -0700
++++ b/test/git/test_git.py     2020-04-11 23:47:01.929316371 -0700
+@@ -8,7 +8,8 @@
+ import tempfile
+-from pkg_resources import parse_version, SetuptoolsLegacyVersion
++from pkg_resources import parse_version
++from packaging.version import LegacyVersion
+ sys.path.insert(0, "src")
+ import common
+@@ -590,7 +591,7 @@
+     def assertPEP440(self, got, state, tree, runtime):
+         where = "/".join([state, tree, runtime])
+         pv = parse_version(got)
+-        self.assertFalse(isinstance(pv, SetuptoolsLegacyVersion),
++        self.assertFalse(isinstance(pv, LegacyVersion),
+                          "%s: '%s' was not pep440-compatible"
+                          % (where, got))
+         self.assertEqual(str(pv), got,
diff --git a/dev-python/versioneer/versioneer-0.18-r1.ebuild b/dev-python/versioneer/versioneer-0.18-r1.ebuild
new file mode 100644 (file)
index 0000000..010def1
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy VCS-based management of project version strings"
+HOMEPAGE="https://pypi.org/project/versioneer/ https://github.com/warner/python-versioneer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+       test? ( dev-vcs/git )
+"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-0.18-fix_test_git.patch"
+)
+
+python_test() {
+       esetup.py make_versioneer
+
+       git config --global user.email "you@example.com"
+       git config --global user.name "Your Name"
+
+       ${PYTHON} test/git/test_git.py -v || die
+}