sys-fs/xfsprogs: Bump to version 5.1.0
authorLars Wendler <polynomial-c@gentoo.org>
Sat, 20 Jul 2019 08:41:55 +0000 (10:41 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 20 Jul 2019 08:45:26 +0000 (10:45 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-fs/xfsprogs/Manifest
sys-fs/xfsprogs/xfsprogs-5.1.0.ebuild [new file with mode: 0644]

index ca938014d2aeeee9d10740b0fb712d1ed20c5e9a..14246274883c8d603462c134aca795268e464364 100644 (file)
@@ -2,3 +2,4 @@ DIST xfsprogs-4.17.0.tar.xz 1205508 BLAKE2B 46168792c1e4c335b7ed9e7489afc20d7df4
 DIST xfsprogs-4.19.0.tar.xz 1212852 BLAKE2B 2d04390765c5e0dd7d51366f0310c9e680651d49bdd1ecd220b4eec50540a66c97bf6e54f976414351bc77381ffd463803836b27ca25b53960a278a34bc09775 SHA512 a96d0ce406534e70b0a531dfab296de420ec710cd0682dffaf5211602adf82dd59f84b9eb7793c54eabb782a9e0229acf7b247ab644d531ee9e5b51fe9dc0f58
 DIST xfsprogs-4.20.0.tar.xz 1215968 BLAKE2B 40aefb8fb899ae96c256f5fdb1c6e841bb450c3fad0487a6097c7f17c40a96a340e073538932d746f04f078afb960f16a34f5d15f500ce804fc842b91a0787e9 SHA512 6adf93fbe20d6b3250c4690237bda041a6dd0cfdc2387f5c88704fc06e6f095bf047964d701ccd65efef7607c15fb8e97b6046f3d631ef327aa8f4c118a36e22
 DIST xfsprogs-5.0.0.tar.xz 1218476 BLAKE2B ef6eaab43531f696f739972c362e31c3304baaecb3485b45c16441a8bf7f1da7f47cd74a21660ba2c2bb45858a2b13b7af41c94671135f6a32a36eb745c024a0 SHA512 cebe3d2ea80676a99cc7f9cc014894398fbe3bdaf237829e9c7aa0404558c1ab16f2055acb5afd8234b2bc8475117bcef3c7500c553adb12bbaf3262bd077d18
+DIST xfsprogs-5.1.0.tar.xz 1223736 BLAKE2B bfadb13cf3a4f9231eb13f4e7d3c803c2143abb776c0fee758ea7257097ef3fb79253c16133942041c20ff6078a1704fa18d08866c6a2e1a61b63f4de11d00c7 SHA512 ca5959edb299be8574b2ca51e907a418fab796ae92f588075a2aab0c2a3cf8dae49e2b68679c65c361201223e8f8ac29b1e5618eb1e519496c3aca9218620881
diff --git a/sys-fs/xfsprogs/xfsprogs-5.1.0.ebuild b/sys-fs/xfsprogs/xfsprogs-5.1.0.ebuild
new file mode 100644 (file)
index 0000000..2bba459
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs multilib systemd usr-ldscript
+
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="https://xfs.wiki.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="icu libedit nls readline static-libs"
+
+LIB_DEPEND=">=sys-apps/util-linux-2.17.2[static-libs(+)]
+       icu? ( dev-libs/icu:=[static-libs(+)] )
+       readline? ( sys-libs/readline:0=[static-libs(+)] )
+       !readline? ( libedit? ( dev-libs/libedit[static-libs(+)] ) )"
+RDEPEND="${LIB_DEPEND//\[static-libs(+)]}
+       !<sys-fs/xfsdump-3"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-4.9.0-underlinking.patch
+       "${FILESDIR}"/${PN}-4.15.0-sharedlibs.patch
+       "${FILESDIR}"/${PN}-4.15.0-docdir.patch
+)
+
+pkg_setup() {
+       if use readline && use libedit ; then
+               ewarn "You have USE='readline libedit' but these are exclusive."
+               ewarn "Defaulting to readline; please disable this USE flag if you want libedit."
+       fi
+}
+
+src_prepare() {
+       default
+
+       # Clear out -static from all flags since we want to link against dynamic xfs libs.
+       sed -i \
+               -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+               include/builddefs.in || die
+       # Don't install compressed docs
+       sed 's@\(CHANGES\)\.gz[[:space:]]@\1 @' -i doc/Makefile || die
+       find -name Makefile -exec \
+               sed -i -r -e '/^LLDFLAGS [+]?= -static(-libtool-libs)?$/d' {} +
+}
+
+src_configure() {
+       export DEBUG=-DNDEBUG
+       export OPTIMIZER=${CFLAGS}
+       unset PLATFORM # if set in user env, this breaks configure
+
+       local myconf=(
+               --disable-lto #655638
+               --enable-blkid
+               --with-crond-dir="${EPREFIX}/etc/cron.d"
+               --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+               $(use_enable icu libicu)
+               $(use_enable nls gettext)
+               $(use_enable readline)
+               $(usex readline --disable-editline $(use_enable libedit editline))
+               $(use_enable static-libs static)
+       )
+
+       econf "${myconf[@]}"
+
+       MAKEOPTS+=" V=1"
+}
+
+src_install() {
+       emake DIST_ROOT="${ED}" install
+       # parallel install fails on this target for >=xfsprogs-3.2.0
+       emake -j1 DIST_ROOT="${ED}" install-dev
+
+       # handle is for xfsdump, the rest for xfsprogs
+       gen_usr_ldscript -a handle xcmd xfs xlog frog
+       # removing unnecessary .la files if not needed
+       if ! use static-libs ; then
+               find "${ED}" -type f -name '*.la' -delete || die
+       fi
+}