dev-tcltk/tclpython: Remove old (py2)
authorMichał Górny <mgorny@gentoo.org>
Mon, 10 Feb 2020 11:38:35 +0000 (12:38 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 10 Feb 2020 11:54:06 +0000 (12:54 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-tcltk/tclpython/tclpython-4.1-r4.ebuild [deleted file]

diff --git a/dev-tcltk/tclpython/tclpython-4.1-r4.ebuild b/dev-tcltk/tclpython/tclpython-4.1-r4.ebuild
deleted file mode 100644 (file)
index 3508b6c..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib python-single-r1 toolchain-funcs
-
-DESCRIPTION="Python package for Tcl"
-HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
-SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
-       dev-lang/tcl:0="
-RDEPEND="${DEPEND}"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-python-3.patch
-)
-
-src_prepare() {
-       epatch "${PATCHES[@]}"
-}
-
-src_compile() {
-       local cfile="tclpython tclthread"
-       for src in ${cfile}; do
-               compile="$(tc-getCC) -shared -fPIC ${CFLAGS} -I$(python_get_includedir) -c ${src}.c"
-               einfo "${compile}"
-               eval "${compile}" || die
-       done
-
-       link="$(tc-getCC) -fPIC -shared ${LDFLAGS} -o tclpython.so.${PV} tclpython.o tclthread.o -lpthread -lutil $(python_get_LIBS) -ltcl"
-       einfo "${link}"
-       eval "${link}" || die
-}
-
-src_install() {
-       insinto /usr/$(get_libdir)/tclpython
-       doins tclpython.so.${PV} pkgIndex.tcl
-       fperms 775 /usr/$(get_libdir)/tclpython/tclpython.so.${PV}
-       dosym tclpython.so.${PV} /usr/$(get_libdir)/tclpython/tclpython.so
-
-       dodoc CHANGES INSTALL README
-       dohtml tclpython.htm
-}