media-libs/gstreamer: Version bump, 1.16.2
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>
Sat, 15 Feb 2020 21:40:39 +0000 (22:40 +0100)
committerMart Raudsepp <leio@gentoo.org>
Sun, 3 May 2020 19:11:49 +0000 (22:11 +0300)
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-libs/gstreamer/Manifest
media-libs/gstreamer/gstreamer-1.16.2.ebuild [new file with mode: 0644]

index 231ffa797ccde5c891a2c17a8f15432b24a6d79e..11b746384b844040f8265a8e3fbce22bed563ce7 100644 (file)
@@ -1 +1,2 @@
 DIST gstreamer-1.14.5.tar.xz 3268756 BLAKE2B 6ef5bdcb103b4d8fd581ae7342d6d467f4c6919610bdd620e4a531755347d8e3276a50f2e637045b9b97cbf7726495608437c180d37a1019ec8a79ab1bc4e4d6 SHA512 1a97ae17f8fff041db5e24d712d33c7116e408be1fabc2abd7b652b067b6ebe6c0943845a33a21335a5b4fa0a1ba178873158659f761f1e3aab04a969029c5d8
+DIST gstreamer-1.16.2.tar.xz 3328600 BLAKE2B 9bc12330fc5a7fa3a65e2c03f9d06172d787e9aadb4c2cb7d98f8f7c5850e05535cf23f747bf89514a609447f3894942bcb2fa4a6d3d3406e129e1eb67b49158 SHA512 a8dcdb452a88f411676e54016fcf83149068b2f0b60422bebdbc81220078c61c415512006010ba0299df81ffb59853695c3ce00580f8fc46a079f6aaaa42609f
diff --git a/media-libs/gstreamer/gstreamer-1.16.2.ebuild b/media-libs/gstreamer/gstreamer-1.16.2.ebuild
new file mode 100644 (file)
index 0000000..5160237
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 multilib-minimal pax-utils
+
+DESCRIPTION="Open source multimedia framework"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+caps +introspection nls +orc test unwind"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+       caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
+       introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+       unwind? (
+               >=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
+               dev-libs/elfutils[${MULTILIB_USEDEP}]
+       )
+       !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}
+       dev-util/glib-utils
+       >=dev-util/gtk-doc-am-1.12
+       sys-devel/bison
+       sys-devel/flex
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+       nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.14.5-make43.patch # remove when bumping and switching to Meson
+)
+
+src_configure() {
+       if [[ ${CHOST} == *-interix* ]] ; then
+               export ac_cv_lib_dl_dladdr=no
+               export ac_cv_func_poll=no
+       fi
+       if [[ ${CHOST} == powerpc-apple-darwin* ]] ; then
+               # GCC groks this, but then refers to an implementation (___multi3,
+               # ___udivti3) that don't exist (at least I can't find it), so force
+               # this one to be off, such that we use 2x64bit emulation code.
+               export gst_cv_uint128_t=no
+       fi
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       local completiondir=$(get_bashcompdir)
+       # Set 'libexecdir' to ABI-specific location for the library spawns
+       # helpers from there.
+       # Disable static archives and examples to speed up build time
+       # Disable debug, as it only affects -g passing (debugging symbols), this must done through make.conf in gentoo
+       local myconf=(
+               --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+               --disable-benchmarks
+               --disable-debug
+               --disable-examples
+               --disable-static
+               --disable-valgrind
+               --enable-check
+               $(use_with unwind)
+               $(use_with unwind dw)
+               $(multilib_native_use_enable introspection)
+               $(use_enable nls)
+               $(use_enable test tests)
+               --with-bash-completion-dir="${completiondir%/*}"
+               --with-package-name="GStreamer ebuild for Gentoo"
+               --with-package-origin="https://packages.gentoo.org/package/media-libs/gstreamer"
+       )
+
+       if use caps ; then
+               myconf+=( --with-ptp-helper-permissions=capabilities )
+       else
+               myconf+=(
+                       --with-ptp-helper-permissions=setuid-root
+                       --with-ptp-helper-setuid-user=nobody
+                       --with-ptp-helper-setuid-group=nobody
+               )
+       fi
+
+       ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+       if multilib_is_native_abi; then
+               local x
+               for x in gst libs plugins; do
+                       ln -s "${S}"/docs/${x}/html docs/${x}/html || die
+               done
+       fi
+}
+
+multilib_src_install() {
+       # can't do "default", we want to install docs in multilib_src_install_all
+       emake DESTDIR="${D}" install
+
+       # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+       use orc && pax-mark -m "${ED}usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
+}
+
+multilib_src_install_all() {
+       DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
+       einstalldocs
+       find "${ED}" -name '*.la' -delete || die
+
+       # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+       use orc && pax-mark -m "${ED}usr/bin/gst-launch-${SLOT}"
+}