dev-ml/gsl-ocaml: New package, successor of dev-ml/ocamlgsl
authorDavid Seifert <soap@gentoo.org>
Sun, 14 Feb 2016 22:04:34 +0000 (23:04 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 14 Feb 2016 22:18:39 +0000 (23:18 +0100)
Gentoo-Bug: 574564

Package-Manager: portage-2.2.27

dev-ml/gsl-ocaml/Manifest [new file with mode: 0644]
dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild [new file with mode: 0644]
dev-ml/gsl-ocaml/metadata.xml [new file with mode: 0644]

diff --git a/dev-ml/gsl-ocaml/Manifest b/dev-ml/gsl-ocaml/Manifest
new file mode 100644 (file)
index 0000000..4a14aa7
--- /dev/null
@@ -0,0 +1 @@
+DIST gsl-ocaml-1.19.1.tar.gz 167549 SHA256 05891594ed3b4ea0c2f201531aeafce1280b937a18ba76d818760252c2b34b66 SHA512 be199d46479f07a16d2f667d7a29675171bc4ecc5a6e5948335bf98f72e6f12474d16455a22e6bfc73683f1d67de3a186d75f817f398f6621241b640c333e07d WHIRLPOOL 85f687b24dacde0d3c6f9f2c1920583e30e57f02e1f6d4dc797db3a846090d2c60d7509b3d70b2374aa31d6b4a9658acb578012f8671d024a24e90e3f5e748a2
diff --git a/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild b/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild
new file mode 100644 (file)
index 0000000..62b3dcb
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="OCaml bindings for the GSL library (successor of dev-ml/ocamlgsl)"
+HOMEPAGE="https://github.com/mmottl/gsl-ocaml"
+SRC_URI="https://github.com/mmottl/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND=">=sci-libs/gsl-1.10"
+RDEPEND="${DEPEND}
+       !dev-ml/ocamlgsl"
+
+DOCS=( CHANGES.txt README.md NOTES.md TODO.md )
+
+src_prepare() {
+       oasis_configure_opts="$(use_enable examples)"
+}
diff --git a/dev-ml/gsl-ocaml/metadata.xml b/dev-ml/gsl-ocaml/metadata.xml
new file mode 100644 (file)
index 0000000..4fb2e67
--- /dev/null
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>sci@gentoo.org</email>
+    <name>Gentoo Science Project</name>
+  </maintainer>
+  <longdescription lang="en">
+GSL interface for OCaml
+</longdescription>
+  <upstream>
+    <remote-id type="bitbucket">mmottl/gsl-ocaml</remote-id>
+  </upstream>
+</pkgmetadata>