dev-python/setuptools_scm: Bump to 3.3.0
authorMichał Górny <mgorny@gentoo.org>
Wed, 8 May 2019 06:08:33 +0000 (08:08 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 8 May 2019 06:34:29 +0000 (08:34 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools_scm/Manifest
dev-python/setuptools_scm/setuptools_scm-3.3.0.ebuild [new file with mode: 0644]

index a65015f3a3905dc5f8e4f04651d2c1e5fe6e38db..dd118b5c122cb085d533960a3cd99ed139890dd2 100644 (file)
@@ -4,3 +4,4 @@ DIST setuptools_scm-1.16.1.tar.gz 28956 BLAKE2B 6721830e9ef171768afb94e6d6aacb82
 DIST setuptools_scm-2.1.0.tar.gz 32776 BLAKE2B 7a141f3fa826a82931b6c33afd19d3185f98b735451c03651b875051e514eab287b20ee382a9576841b6f1283b9d1bf3dcbd0aabc41d2f1143cf960b856c8492 SHA512 69ce171aa4d3b576883efffb350c59f38bfe8b35bd8e4e8fa1128d9f8a3e6cfaab832633e91fada36126f8e7e2c18663fad621d62c9834be1b5d36c58ae1d1c8
 DIST setuptools_scm-3.1.0.tar.gz 35585 BLAKE2B 7ecbdf325467cb3e5217150c548b99603e1bb851a3bc8c694acf3aeb0da798ec853d13b29ad0537bdf5c1010834576786e0dde3965d61991554a12cf206ba7e0 SHA512 bd84bb02900ddc7de2f02dd7cb62bafdea7040ebdc2506b72d05f2c6a6d16be903321e576f63a04f2aa13d8c75b1834dec7d9ea8444e8330281f8e586a3d6426
 DIST setuptools_scm-3.2.0.tar.gz 39646 BLAKE2B 922e2e09a9826e8573900e8d279daf937289f91f8fead5230ea7082d85275d5d988d655854a36afd48d6b621eaa261ac9a0cd486acc115f0e389fb6828645e8b SHA512 1995754654f8bf509ec7f2186857ba0005dbaea0b1c734f521becb9d022c127e7b36f21da8defd5ec9883de5d0d4afe006f9d152c4cefe6beadf8b878e949eb2
+DIST setuptools_scm-3.3.0.tar.gz 40061 BLAKE2B 374b5d61ba9e4e9a7d5a7f9505ecafe7761d05bd8593a609a1a969af8323ec8fb29793c91276e8540552ef4e31dcca1f993d37374bd01f2c9f97e674447944d1 SHA512 e25be0e7efe56b5dcdaacf31ed512b3396285664a52a14a3d25d9ff4e2d6f3bb8e632d87b78d4ae323e0bbbfd16ac172a7d1b03a6837bf44a9753df1a4b92d0f
diff --git a/dev-python/setuptools_scm/setuptools_scm-3.3.0.ebuild b/dev-python/setuptools_scm/setuptools_scm-3.3.0.ebuild
new file mode 100644 (file)
index 0000000..7ea0510
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="package to manage versions by scm tags via setuptools"
+HOMEPAGE="https://github.com/pypa/setuptools_scm https://pypi.org/project/setuptools_scm/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-vcs/git
+               dev-vcs/mercurial )"
+
+python_prepare_all() {
+       # network access
+       sed -i -e 's:test_pip_download:_&:' testing/test_regressions.py || die
+       # all fetch specific setuptools versions
+       rm testing/test_setuptools_support.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       distutils_install_for_testing
+       py.test -v -v -x || die "Tests fail with ${EPYTHON}"
+}