dev-python/lit: Reorder ebuild vars in 9+
authorMichał Górny <mgorny@gentoo.org>
Sat, 21 Sep 2019 08:32:47 +0000 (10:32 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 21 Sep 2019 09:15:28 +0000 (11:15 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/lit/lit-10.0.0.9999.ebuild
dev-python/lit/lit-9.0.0.9999.ebuild
dev-python/lit/lit-9.0.0.ebuild

index d4566ae8be57aae4c6a9f7e668ea4f3d74a649f6..32320b7920e1b267090e0293501c94344f6e77e7 100644 (file)
@@ -9,6 +9,8 @@ inherit distutils-r1 git-r3 multiprocessing
 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
+S=${WORKDIR}/${P}/utils/lit
+
 EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
        https://github.com/llvm-mirror/llvm.git"
 
@@ -18,8 +20,6 @@ KEYWORDS=""
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-S=${WORKDIR}/${P}/utils/lit
-
 # Tests require 'FileCheck' and 'not' utilities (from llvm)
 BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
index 289c81bd0a5178130b48fb08f0cbf8deb4903206..c9fb8cb2815475242006c20e37540f3dfacdde99 100644 (file)
@@ -9,6 +9,8 @@ inherit distutils-r1 git-r3 multiprocessing
 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
+S=${WORKDIR}/${P}/utils/lit
+
 EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
        https://github.com/llvm-mirror/llvm.git"
 EGIT_BRANCH="release_90"
@@ -19,8 +21,6 @@ KEYWORDS=""
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-S=${WORKDIR}/${P}/utils/lit
-
 # Tests require 'FileCheck' and 'not' utilities (from llvm)
 BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
index 7eb1e80816898dba430e51cef4b5d2830ddc38a1..80e7699557cd1daf3288eb2a6b1967a2aa120477 100644 (file)
@@ -10,6 +10,7 @@ MY_P=llvm-${PV/_/}.src
 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
 HOMEPAGE="https://llvm.org/"
 SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
+S=${WORKDIR}/${MY_P}/utils/lit
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -17,8 +18,6 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd"
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-S=${WORKDIR}/${MY_P}/utils/lit
-
 # Tests require 'FileCheck' and 'not' utilities (from llvm)
 BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]