dev-ros/gazebo_ros: Bump to 2.8.7.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 14:56:41 +0000 (16:56 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 15:18:24 +0000 (17:18 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/gazebo_ros/Manifest
dev-ros/gazebo_ros/gazebo_ros-2.8.7.ebuild [new file with mode: 0644]

index fa8088de10323d00d15b5f2056c4435649839a80..af68829371ed1e52cc2f36785df61b5b85ad675d 100644 (file)
@@ -4,3 +4,4 @@ DIST gazebo_ros_pkgs-2.7.3.tar.gz 1836260 BLAKE2B 7867bec1461769923ba36ea2e56b21
 DIST gazebo_ros_pkgs-2.7.4.tar.gz 1839281 BLAKE2B 3a8342465e69c6b7d986b6a9f04b42451479434839a10ecebc1993ad57ffecf78b1f67013fe54919477a252ef547ab5ed768b4f0303de7395e6a693e1aafced1 SHA512 43c1fed13a653a93df85110d49fcd5d324b80e080cdef08ad15cd293d25b0eca59ec9610e420074f2bf406567a79a8c0b8ae88a289981626f2f5be1dc8b06c22
 DIST gazebo_ros_pkgs-2.8.4.tar.gz 1853755 BLAKE2B 4551557629cb43e651714b2e1a6aca3b127cd769bad47144b1fb769138f5c15cee45ab012a6e695559f42dbd7b0989984a2c979abc8779f63f815f909ec4a411 SHA512 6595e06b1269e2cdf8850a040f40e59a9169cc0790e7b646ba025767a72fc4eabcacd069d1cd3f82b1ca66ff47811df117134323a10e409aa2fe8b9c1f812525
 DIST gazebo_ros_pkgs-2.8.5.tar.gz 1854305 BLAKE2B f82021144b788b5fe19269ad28e1970a5f932ec91f7afdc0e45c4870125138b51cfadd794c08b52836f21e9d07c026cda80656794201b606b11b344ae73847e8 SHA512 124af0cff7933ce61127fd3ea61261e94b154954586af420c78775a6e4c69a741402aa563cb8d12a6b0f8a794a3948533c0a01555b00546c7c89742e43b25666
+DIST gazebo_ros_pkgs-2.8.7.tar.gz 1860830 BLAKE2B 2d0bf4774b1eff0bc658baf101d3450e5d94bcf8603a6e012b8a62422eb6a6b32e3c00c82f2854182ff990cf5017c23dac02d645c6a634d9fdb34403870ffd20 SHA512 3326c88dd7145a5beeaa0bd9c19f6abc2fb5483cfff1748b01c8f137c7223ffef80ff0df5cd0a2cb255006eaa44eef60cc878b362eed4a1d9a43a1a09ad24eaa
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.8.7.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.8.7.ebuild
new file mode 100644 (file)
index 0000000..254d555
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/gazebo_dev
+       dev-libs/tinyxml
+       sci-electronics/gazebo:=
+       dev-libs/protobuf:=
+       dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+       dev-ros/roslib[${PYTHON_USEDEP}]
+       dev-ros/roscpp
+       dev-ros/tf[${PYTHON_USEDEP}]
+       dev-ros/dynamic_reconfigure
+       dev-libs/libxml2
+       dev-libs/boost:=[threads]
+       dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/std_msgs
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"