dev-lang/gnat-gpl: remove src_install (use default)
authorTupone Alfredo <tupone@gentoo.org>
Mon, 25 Nov 2019 21:30:06 +0000 (22:30 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Mon, 25 Nov 2019 21:30:06 +0000 (22:30 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-lang/gnat-gpl/gnat-gpl-2016-r4.ebuild
dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild
dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild
dev-lang/gnat-gpl/gnat-gpl-2019-r1.ebuild

index b54bc1e1b828b3ce846ef32dd2e49e8b9d9ad56e..15eafdcd92a80dfef241cb839b6ec35399500ca3 100644 (file)
@@ -169,38 +169,6 @@ src_compile() {
        gcc_do_make "-C gcc gnattools"
 }
 
-src_install() {
-       toolchain_src_install
-       cd "${D}"${BINPATH}
-       if [[ -h gnatmake-${GCC_CONFIG_VER} ]] ; then
-               return
-       fi
-       for x in gnat*; do
-               # For some reason, g77 gets made instead of ${CTARGET}-g77...
-               # this should take care of that
-               if [[ -f ${x} ]] ; then
-                       # In case they're hardlinks, clear out the target first
-                       # otherwise the mv below will complain.
-                       rm -f ${CTARGET}-${x}
-                       mv ${x} ${CTARGET}-${x}
-               fi
-
-               if [[ -f ${CTARGET}-${x} ]] ; then
-                       ln -sf ${CTARGET}-${x} ${x}
-                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                               /usr/bin/${x}-${GCC_CONFIG_VER}
-                       # Create versioned symlinks
-                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                               /usr/bin/${CTARGET}-${x}-${GCC_CONFIG_VER}
-               fi
-
-               if [[ -f ${CTARGET}-${x}-${GCC_CONFIG_VER} ]] ; then
-                       rm -f ${CTARGET}-${x}-${GCC_CONFIG_VER}
-                       ln -sf ${CTARGET}-${x} ${CTARGET}-${x}-${GCC_CONFIG_VER}
-               fi
-       done
-}
-
 pkg_postinst () {
        toolchain_pkg_postinst
        einfo "This provide the GNAT compiler with gcc for ada/c/c++ and more"
index 0688916c1b721f9ddf81390f0949b7ada3f74104..3c90857c905a7290e8209200b53d4506224c37f0 100644 (file)
@@ -151,38 +151,6 @@ src_compile() {
        gcc_do_make "-C gcc gnattools"
 }
 
-src_install() {
-       toolchain_src_install
-       cd "${D}"${BINPATH}
-       if [[ -h gnatmake-${GCC_CONFIG_VER} ]] ; then
-               return
-       fi
-       for x in gnat*; do
-               # For some reason, g77 gets made instead of ${CTARGET}-g77...
-               # this should take care of that
-               if [[ -f ${x} ]] ; then
-                       # In case they're hardlinks, clear out the target first
-                       # otherwise the mv below will complain.
-                       rm -f ${CTARGET}-${x}
-                       mv ${x} ${CTARGET}-${x}
-               fi
-
-               if [[ -f ${CTARGET}-${x} ]] ; then
-                       ln -sf ${CTARGET}-${x} ${x}
-                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                               /usr/bin/${x}-${GCC_CONFIG_VER}
-                       # Create versioned symlinks
-                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                               /usr/bin/${CTARGET}-${x}-${GCC_CONFIG_VER}
-               fi
-
-               if [[ -f ${CTARGET}-${x}-${GCC_CONFIG_VER} ]] ; then
-                       rm -f ${CTARGET}-${x}-${GCC_CONFIG_VER}
-                       ln -sf ${CTARGET}-${x} ${CTARGET}-${x}-${GCC_CONFIG_VER}
-               fi
-       done
-}
-
 pkg_postinst () {
        toolchain_pkg_postinst
        einfo "This provide the GNAT compiler with gcc for ada/c/c++ and more"
index 8af2aa5ec9d6e139fffdd1112d41aafce366b337..40b80c33c61e8faa6707856a8d9a57e386960758 100644 (file)
@@ -151,38 +151,6 @@ src_compile() {
        gcc_do_make "-C gcc gnattools"
 }
 
-src_install() {
-       toolchain_src_install
-       cd "${D}"${BINPATH}
-       if [[ -h gnatmake-${GCC_CONFIG_VER} ]] ; then
-               return
-       fi
-       for x in gnat*; do
-               # For some reason, g77 gets made instead of ${CTARGET}-g77...
-               # this should take care of that
-               if [[ -f ${x} ]] ; then
-                       # In case they're hardlinks, clear out the target first
-                       # otherwise the mv below will complain.
-                       rm -f ${CTARGET}-${x}
-                       mv ${x} ${CTARGET}-${x}
-               fi
-
-               if [[ -f ${CTARGET}-${x} ]] ; then
-                       ln -sf ${CTARGET}-${x} ${x}
-                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                               /usr/bin/${x}-${GCC_CONFIG_VER}
-                       # Create versioned symlinks
-                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                               /usr/bin/${CTARGET}-${x}-${GCC_CONFIG_VER}
-               fi
-
-               if [[ -f ${CTARGET}-${x}-${GCC_CONFIG_VER} ]] ; then
-                       rm -f ${CTARGET}-${x}-${GCC_CONFIG_VER}
-                       ln -sf ${CTARGET}-${x} ${CTARGET}-${x}-${GCC_CONFIG_VER}
-               fi
-       done
-}
-
 pkg_postinst () {
        toolchain_pkg_postinst
        einfo "This provide the GNAT compiler with gcc for ada/c/c++ and more"
index 00333a9c33b06f2283815160b2d60ff38f1071ec..5aa08b147d38c8a68b72b73e59511b9e3d9d695a 100644 (file)
@@ -150,38 +150,6 @@ src_compile() {
        gcc_do_make "-C gcc gnattools"
 }
 
-src_install() {
-       toolchain_src_install
-       cd "${D}"${BINPATH}
-       if [[ -h gnatmake-${GCC_CONFIG_VER} ]] ; then
-               return
-       fi
-       for x in gnat*; do
-               # For some reason, g77 gets made instead of ${CTARGET}-g77...
-               # this should take care of that
-               if [[ -f ${x} ]] ; then
-                       # In case they're hardlinks, clear out the target first
-                       # otherwise the mv below will complain.
-                       rm -f ${CTARGET}-${x}
-                       mv ${x} ${CTARGET}-${x}
-               fi
-
-               if [[ -f ${CTARGET}-${x} ]] ; then
-                       ln -sf ${CTARGET}-${x} ${x}
-                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                               /usr/bin/${x}-${GCC_CONFIG_VER}
-                       # Create versioned symlinks
-                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                               /usr/bin/${CTARGET}-${x}-${GCC_CONFIG_VER}
-               fi
-
-               if [[ -f ${CTARGET}-${x}-${GCC_CONFIG_VER} ]] ; then
-                       rm -f ${CTARGET}-${x}-${GCC_CONFIG_VER}
-                       ln -sf ${CTARGET}-${x} ${CTARGET}-${x}-${GCC_CONFIG_VER}
-               fi
-       done
-}
-
 pkg_postinst () {
        einfo "This provide the GNAT compiler with gcc for ada/c/c++ and more"
        einfo "The compiler binary is ${CTARGET}-gcc-${GCC_CONFIG_VER}"