app-laptop/thinkfan: version bump to 0.9.3.
authorAmir Ghassemi Nasr <Ameretat.Reith@gmail.com>
Mon, 5 Dec 2016 12:39:41 +0000 (16:09 +0330)
committerPatrice Clement <monsieurp@gentoo.org>
Wed, 21 Dec 2016 10:46:21 +0000 (11:46 +0100)
Gentoo-Bug: https://bugs.gentoo.org/597846

Closes: https://github.com/gentoo/gentoo/pull/3019

app-laptop/thinkfan/Manifest
app-laptop/thinkfan/thinkfan-0.9.3.ebuild [new file with mode: 0644]

index 709a139494ae831f66287bc03123e329bf566029..a27bf752affd3eb5931ee2a3ac3e7666391cd49c 100644 (file)
@@ -1,3 +1,4 @@
 DIST thinkfan-0.8.1.tar.gz 38417 SHA256 ba630fdcdefa238b2c87f050f6fcbd5a4828527497d52d410761a26c8ca25311 SHA512 6e5c7df599ca6f1c99cf61bfafb752f5886a7eeff9166a43006ea8d86f82ff8c4d5eb6ddc2e62dc5d01235038b4606fbbfc849f81b971388ccbe6417ee9f3208 WHIRLPOOL 975eee0b64db52bbd5552a540aff035abe36bd8a602ec6f966ec30a9ffd1bc9ef30481b91f37c6c3f771a2ba0b38850d7d4dc40387c475deffa7850288d122b4
 DIST thinkfan-0.9.2.tar.gz 39539 SHA256 90daa0f2db221e1d5085d7f25cb6c63608d174db2987478c340e9523e652af79 SHA512 b27fd60a02ad06d30485ae3d658af6b9e79af3c898f415d0ff613839424f5dc9731be03d1d9bf3ed1311ecd0778aef5b30fa908cab386cf419db77ae29940684 WHIRLPOOL 2ca120ad9cf4960c7536cf6252b711257cbb7c1ca6061d028aebf53fd18e41d3b852d36158bddd18f791e1128b98d35a3f68fae5bb29077820f4dff6fc9b1919
+DIST thinkfan-0.9.3.tar.gz 39527 SHA256 b61c634996c450445d7e440bf41f7adcda86506063f832afa40d44e01061e45b SHA512 d2a29f9cae636c22b66958f8ec50cb60a162d745c3967257bb5e20cc9e152894d4e8a66f897ffa4e49353eba4a42e3499bb9e554719974284089a46cfc6280d7 WHIRLPOOL 3bdbc0ca3731fef85e385b3259cc9ce6bf4c3b15195138caf5b192847bbba411068d00df8e5673600796e15d4d965c116b73745e787bea9f5a68dbbb5ee118db
 DIST thinkfan-0.9_beta2.tar.gz 41554 SHA256 0db4a0e56c02b991be13741f622a8e475a8361112ff9a38a0430ccc22f104a39 SHA512 3cf1b33de625a663b32482943f99dba88cc09106c1b96701ba6a36a5ea1abb3cfd8b32c3822af93d1cf19ab25c61370abca5bd0b313a9fb055dd191086c1df01 WHIRLPOOL 1a8e71fb0906fb11c5922f09e6136f48cbcb7128525fafeeb7f3474f01a00eeb046f69b2d5788428828a395dbc11ae084e9655259a1a74f6aafe04ca8417d4ad
diff --git a/app-laptop/thinkfan/thinkfan-0.9.3.ebuild b/app-laptop/thinkfan/thinkfan-0.9.3.ebuild
new file mode 100644 (file)
index 0000000..9691a05
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils readme.gentoo-r1 systemd
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atasmart"
+
+DEPEND="atasmart? ( dev-libs/libatasmart )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       cmake-utils_src_prepare
+
+       sed -e "s:#!/sbin/runscript:#!/sbin/openrc-run:" \
+               -i rcscripts/thinkfan.gentoo
+
+       sed -e "s:share/doc/${PN}:share/doc/${PF}:" \
+           -e "s:thinkfan.1:src/thinkfan.1:" \
+               -i CMakeLists.txt
+}
+
+src_configure() {
+       local mycmakeargs+=(
+               "-DCMAKE_BUILD_TYPE:STRING=Debug"
+               "-DUSE_ATASMART=$(usex atasmart)"
+       )
+
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       newinitd rcscripts/${PN}.gentoo ${PN}
+       systemd_dounit rcscripts/${PN}.service
+
+       readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please read the documentation and copy an
+appropriate file to /etc/thinkfan.conf."