dev-lang/nim: bump up to 0.20.0
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 8 Jun 2019 09:08:06 +0000 (10:08 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 8 Jun 2019 09:09:14 +0000 (10:09 +0100)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-lang/nim/Manifest
dev-lang/nim/files/nim-0.20.0-paths.patch [new file with mode: 0644]
dev-lang/nim/nim-0.20.0.ebuild [new file with mode: 0644]

index 3de80cdb9b042d138804b4dc7f0ffa75e3cbae77..907dcc3e525d3fde31b16fb1d058099ecab91bd2 100644 (file)
@@ -1,2 +1,3 @@
 DIST nim-0.19.4.tar.xz 4284092 BLAKE2B 7fcc4d4c13cd5ab0b9ac7b98b3ffff99ffcb77d0a23bb731b92813b5d96f5ce88303cb0196ad425f5944744f30aa1d257dc90714f6d11c1a26726ad4512206b7 SHA512 0cf87368b51bc305935b350b63c535ed268c066258ef731b73c12afaa9a3c20760876e3c4bec46448051fe8bacb6c4f1ef84f2ec3789f601a4786408bf3da06c
 DIST nim-0.19.6.tar.xz 4166952 BLAKE2B 6be2cf16bc7807fe78e3d30d9533ab3c1eff1c2042c6af1aca0d7e8330597f2aaa363085f8da2448075be6cb1feb07186c28a32fb58f120af8f4db009dcd4561 SHA512 9728825e349570ec187c031725162b70fdb1a43229732d33fcfa61dde84fb6392c7265a456ce925fd7d1d782d7f9881398173bf69c0d1ecdbefbbb6bd57f6041
+DIST nim-0.20.0.tar.xz 4997088 BLAKE2B fd03837c1674052145cbed631be4d4028a31fdd46d8b730734781b65d5bbcd9cb118ef7ac14c1bc16f7e056365b5bddf32160bf84566ac4815cb12e330f8e712 SHA512 e41fc9f9337535d07ebdd14ae8195bf9c666a0a242516f24d50241e69d50e89fcb9ac1a0b1fbeee0bc75b0218aeb18698ff2ac87447005dad52dc18da80bb02d
diff --git a/dev-lang/nim/files/nim-0.20.0-paths.patch b/dev-lang/nim/files/nim-0.20.0-paths.patch
new file mode 100644 (file)
index 0000000..a314eae
--- /dev/null
@@ -0,0 +1,36 @@
+Default to <prefix>/usr/bin install.
+
+https://bugs.gentoo.org/635032
+--- a/tools/niminst/install.nimf
++++ b/tools/niminst/install.nimf
+@@ -28,13 +28,13 @@ if [ $# -eq 1 ] ; then
+       echo "sh deinstall.sh DIR"
+       exit 1
+       ;;
+-    "/usr/bin")
+-      bindir=/usr/bin
+-      configdir=/etc/?proj
+-      libdir=/usr/lib/?proj
+-      docdir=/usr/share/?proj/doc
+-      datadir=/usr/share/?proj/data
+-      nimbleDir="/opt/nimble/pkgs/?c.nimblePkgName-?c.version"
++    *)
++      bindir=$1/usr/bin
++      configdir=$1/etc/?proj
++      libdir=$1/usr/lib/?proj
++      docdir=$1/usr/share/?proj/doc
++      datadir=$1/usr/share/?proj/data
++      nimbleDir=$1"/opt/nimble/pkgs/?c.nimblePkgName-?c.version"
+       ;;
+     "/usr/local/bin")
+       bindir=/usr/local/bin
+@@ -68,6 +68,9 @@ if [ $# -eq 1 ] ; then
+       ;;
+   esac
++  mkdir -p $bindir
++  mkdir -p $datadir
++
+   mkdir -p $libdir
+   mkdir -p $docdir
+   mkdir -p $configdir
diff --git a/dev-lang/nim/nim-0.20.0.ebuild b/dev-lang/nim/nim-0.20.0.ebuild
new file mode 100644 (file)
index 0000000..bb41a87
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 multiprocessing toolchain-funcs
+
+DESCRIPTION="compiled, garbage-collected systems programming language"
+HOMEPAGE="https://nim-lang.org/"
+SRC_URI="https://nim-lang.org/download/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc +readline test"
+
+RESTRICT=test # need to sort out depends and numerous failures
+
+RDEPEND="
+       readline? ( sys-libs/readline:0= )
+"
+DEPEND="
+       ${DEPEND}
+       test? ( net-libs/nodejs )
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.20.0-paths.patch
+)
+
+_run() {
+       echo "$@"
+       "$@" || die "'$*' failed"
+}
+
+nim_use_enable() {
+       [[ -z $2 ]] && die "usage: nim_use_enable <USE flag> <compiler flag>"
+       use $1 && echo "-d:$2"
+}
+
+src_compile() {
+       export XDG_CACHE_HOME=${T}/cache #667182
+       tc-export CC LD
+
+       _run ./build.sh
+
+       _run ./bin/nim --parallelBuild:$(makeopts_jobs) c koch
+       _run ./koch boot --parallelBuild:$(makeopts_jobs) -d:release $(nim_use_enable readline useGnuReadline)
+       # build nimble and friends
+       # --stable to avoid pulling HEAD nimble
+       PATH="./bin:$PATH" _run ./koch --stable tools
+
+       if use doc; then
+               PATH="./bin:$PATH" _run ./koch doc
+       fi
+}
+
+src_test() {
+       PATH="./bin:$PATH" _run ./koch test
+}
+
+src_install() {
+       PATH="./bin:$PATH" _run ./koch install "${ED%/}"
+       rm -r "${ED%/}/usr/share/nim/doc" || die "failed to remove 'doc'"
+
+       exeinto /usr/bin
+
+       local bin_exe
+       for bin_exe in bin/*; do
+               # './koch install' installs only 'nim' binary
+               # but not the rest
+               [[ ${bin_exe} == bin/nim ]] && continue
+               doexe "${bin_exe}"
+       done
+
+       if use doc; then
+               insinto /usr/share/doc/${PF}
+               dodoc doc/html/*.html
+       fi
+
+       newbashcomp tools/nim.bash-completion ${PN}
+}