sys-apps/lsb-release: Drop old (EAPI=0)
authorMichał Górny <mgorny@gentoo.org>
Sat, 5 Oct 2019 07:59:16 +0000 (09:59 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 5 Oct 2019 07:59:16 +0000 (09:59 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-apps/lsb-release/lsb-release-1.4-r1.ebuild [deleted file]
sys-apps/lsb-release/lsb-release-1.4-r2.ebuild [deleted file]
sys-apps/lsb-release/lsb-release-1.4.ebuild [deleted file]

diff --git a/sys-apps/lsb-release/lsb-release-1.4-r1.ebuild b/sys-apps/lsb-release/lsb-release-1.4-r1.ebuild
deleted file mode 100644 (file)
index 933dc29..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils
-
-DESCRIPTION="LSB version query program"
-HOMEPAGE="https://wiki.linuxfoundation.org/lsb/"
-SRC_URI="mirror://sourceforge/lsb/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-# Perl isn't needed at runtime, it is just used to generate the man page.
-DEPEND="dev-lang/perl"
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-os-release.patch # bug 443116
-}
-
-src_install() {
-       emake \
-               prefix="${D}/usr" \
-               mandir="${D}/usr/share/man" \
-               install
-
-       dodir /etc
-       cat > "${D}/etc/lsb-release" <<- EOF
-               DISTRIB_ID="Gentoo"
-       EOF
-}
diff --git a/sys-apps/lsb-release/lsb-release-1.4-r2.ebuild b/sys-apps/lsb-release/lsb-release-1.4-r2.ebuild
deleted file mode 100644 (file)
index df16c8c..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils
-
-DESCRIPTION="LSB version query program"
-HOMEPAGE="https://wiki.linuxfoundation.org/lsb/"
-SRC_URI="mirror://sourceforge/lsb/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-# Perl isn't needed at runtime, it is just used to generate the man page.
-DEPEND="dev-lang/perl"
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-os-release.patch # bug 443116
-
-       # use POSIX 'printf' instead of bash 'echo -e', bug #482370
-       sed -i -e "s:echo -e:printf '%b\\\n':g" lsb_release || die
-}
-
-src_install() {
-       emake \
-               prefix="${D}/usr" \
-               mandir="${D}/usr/share/man" \
-               install
-
-       dodir /etc
-       cat > "${D}/etc/lsb-release" <<- EOF
-               DISTRIB_ID="Gentoo"
-       EOF
-}
diff --git a/sys-apps/lsb-release/lsb-release-1.4.ebuild b/sys-apps/lsb-release/lsb-release-1.4.ebuild
deleted file mode 100644 (file)
index 312c56d..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-DESCRIPTION="LSB version query program"
-HOMEPAGE="https://wiki.linuxfoundation.org/lsb/"
-SRC_URI="mirror://sourceforge/lsb/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-# Perl isn't needed at runtime, it is just used to generate the man page.
-DEPEND="dev-lang/perl"
-RDEPEND=""
-
-src_install() {
-       emake \
-               prefix="${D}/usr" \
-               mandir="${D}/usr/share/man" \
-               install \
-               || die "emake install failed"
-
-       mkdir -p "${D}/etc"
-       cat > "${D}/etc/lsb-release" <<- EOF
-               DISTRIB_ID="Gentoo"
-       EOF
-}