app-text/mupdf: Version bump (v1.16.1)
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 13 Oct 2019 10:50:54 +0000 (13:50 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 13 Oct 2019 10:51:50 +0000 (13:51 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-text/mupdf/Manifest
app-text/mupdf/mupdf-1.16.1.ebuild [new file with mode: 0644]

index c8ad1a8bd31f72b6691fa7294395cc89c9f6cccb..9142b4ccaf02bd115832ddda52c13906c58dad45 100644 (file)
@@ -1,2 +1,3 @@
 DIST mupdf-1.14.0-source.tar.xz 41602372 BLAKE2B bb680038344af16c7231a18a009c0d04c5f50b3fcbaf061c9f5907f35d79eea93eeced7c2a43a06a963b93b39c74d0246c5fdad35655953d1aa5efb79737265a SHA512 bd41125dac1a81b7dbbfbb5f5e06e70bb601854731e0945983688da5d8d7c0bca9771fff2e4b6d9c36dbead6146f0a866ed7427d58e13d02ed6dfd94dcfe54bf
 DIST mupdf-1.15.0-source.tar.xz 39828864 BLAKE2B 15d0e4244062a91c7055b98fa61f2b02e0e3effbcf5374fe589f5a0d2ba2a2d4a59318ae3c0f28d866c6b07554e4b1e65ee9264c26a5f4524ef34e998d6c3320 SHA512 ef19362e8b6c2843e214fd2fcdcc9ba91017884383f7e1cfe08ef1f528a233820475ddfdd8aef481e6e37ae69e8b64324eb4b30699baa8055e99e47c2fab31dd
+DIST mupdf-1.16.1-source.tar.xz 45800404 BLAKE2B bc4158a457056c55db52a518efc13c289cca537c29a6b563046297dc225f3ce0add781adb8520c4d0829d653ed0539042597e341cb21c4fb4c462ed422bf735b SHA512 fa657e6b9251aff91c25e91b335ea829b797dd91a759505bfd7259f8236613f590a044bc741e9b0587da55817a1ab8c1499c067d65d683d099259d06d91a8f50
diff --git a/app-text/mupdf/mupdf-1.16.1.ebuild b/app-text/mupdf/mupdf-1.16.1.ebuild
new file mode 100644 (file)
index 0000000..58fd2c4
--- /dev/null
@@ -0,0 +1,127 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs xdg desktop
+
+DESCRIPTION="a lightweight PDF viewer and toolkit written in portable C"
+HOMEPAGE="https://mupdf.com/"
+SRC_URI="https://mupdf.com/downloads/archive/${P}-source.tar.xz"
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="X +javascript libressl opengl ssl static-libs"
+
+# Although we use the bundled, patched version of freeglut in mupdf (because of
+# bug #653298), the best way to ensure that its dependencies are present is to
+# install system's freeglut.
+RDEPEND="
+       media-libs/freetype:2=[static-libs?]
+       media-libs/harfbuzz:=[static-libs?,truetype]
+       media-libs/jbig2dec:=[static-libs?]
+       media-libs/libpng:0=[static-libs?]
+       >=media-libs/openjpeg-2.1:2=[static-libs?]
+       virtual/jpeg[static-libs?]
+       opengl? ( >=media-libs/freeglut-3.0.0:= )
+       ssl? (
+               libressl? ( >=dev-libs/libressl-2.8:0=[static-libs?] )
+               !libressl? ( >=dev-libs/openssl-1.1:0=[static-libs?] )
+       )
+       X? (
+               x11-libs/libX11[static-libs?]
+               x11-libs/libXext[static-libs?]
+       )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+REQUIRED_USE="opengl? ( !static-libs )"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.15-CFLAGS.patch
+       "${FILESDIR}"/${PN}-1.15-Makefile.patch
+       "${FILESDIR}"/${PN}-1.10a-add-desktop-pc-xpm-files.patch
+       # See bugs #662352
+       "${FILESDIR}"/${PN}-1.15-openssl-x11.patch
+)
+
+src_prepare() {
+       xdg_src_prepare
+       use hppa && append-cflags -ffunction-sections
+
+       use javascript || \
+               sed -e '/* #define FZ_ENABLE_JS/ a\#define FZ_ENABLE_JS 0' \
+                       -i include/mupdf/fitz/config.h
+
+       # See bug #670832
+       use ssl && use libressl && eapply "${FILESDIR}"/${PN}-1.14-libressl.patch
+
+       sed -e "1iOS = Linux" \
+               -e "1iCC = $(tc-getCC)" \
+               -e "1iLD = $(tc-getLD)" \
+               -e "1iAR = $(tc-getAR)" \
+               -e "1iverbose = yes" \
+               -e "1ibuild = debug" \
+               -e "1iprefix = ${ED}/usr" \
+               -e "1ilibdir = ${ED}/usr/$(get_libdir)" \
+               -e "1idocdir = ${ED}/usr/share/doc/${PF}" \
+               -i Makerules || die
+}
+
+_emake() {
+       # When HAVE_OBJCOPY is yes, we end up with a lot of QA warnings.
+
+       # We don't use system's freeglut because upstream has a special modified
+       # version of it that gives mupdf clipboard support. See bug #653298
+
+       # As of v1.15.0, mupdf started using symbols in mujs that were not part
+       # of any release. We thus go back to using the bundled version of it.
+       # Bug #685244
+       emake \
+               GENTOO_PV=${PV} \
+               HAVE_GLUT=$(usex opengl) \
+               HAVE_LIBCRYPTO=$(usex ssl) \
+               HAVE_X11=$(usex X) \
+               USE_SYSTEM_LIBS=yes \
+               USE_SYSTEM_MUJS=no \
+               USE_SYSTEM_GLUT=no \
+               HAVE_OBJCOPY=no \
+               "$@"
+}
+
+src_compile() {
+       _emake XCFLAGS="-fpic"
+
+       use static-libs && \
+               _emake build/debug/lib${PN}.a
+}
+
+src_install() {
+       if use X || use opengl ; then
+               domenu platform/debian/${PN}.desktop
+               doicon platform/debian/${PN}.xpm
+       else
+               rm docs/man/${PN}.1
+       fi
+
+       _emake install
+
+       dosym libmupdf.so.${PV} /usr/$(get_libdir)/lib${PN}.so
+
+       use static-libs && \
+               dolib.a build/debug/lib${PN}.a
+       if use opengl ; then
+               einfo "mupdf symlink points to mupdf-gl (bug 616654)"
+               dosym ${PN}-gl /usr/bin/${PN}
+       elif use X ; then
+               einfo "mupdf symlink points to mupdf-x11 (bug 616654)"
+               dosym ${PN}-x11 /usr/bin/${PN}
+       fi
+       insinto /usr/$(get_libdir)/pkgconfig
+       doins platform/debian/${PN}.pc
+
+       dodoc README CHANGES CONTRIBUTORS
+}