sci-visualization/gfsview: Don't set LIBS in global scope
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:24:16 +0000 (18:24 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:30:35 +0000 (18:30 +0200)
* determine libGL via pkg-config
* drop old
* BUMP EAPI to 5

Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sci-visualization/gfsview/Manifest
sci-visualization/gfsview/gfsview-20111003.ebuild [deleted file]
sci-visualization/gfsview/gfsview-20120706-r1.ebuild [moved from sci-visualization/gfsview/gfsview-20120706.ebuild with 67% similarity]
sci-visualization/gfsview/metadata.xml

index 65823fa784b06882bf37ecb02191f6ea8c1b85b5..3c100d79f71980dc84af550425d03636ec1856ec 100644 (file)
@@ -1,2 +1 @@
-DIST gfsview-20111003.tar.gz 703942 SHA256 448e03c730af3a2cca233f17a44bfda46f5400052ea1ed0f3dc863c8050b1122 SHA512 736394fd403e4b089251819e03b6aab31fe13db451e9bb9a9bf7b728dc64461e61323c38a63dae9ed855a5c213dc03fd5875c0332353420bd6ce4edb8a7eea24 WHIRLPOOL b834a7364eabac0bfe12789ff331507b188f9cc0fbbe505b57aea8c99998b7a6898842b427c7b0df60fcd23c776c9854793e37d5d5a436b306a8d882e4be3ec6
 DIST gfsview-snapshot-120706.tar.gz 707640 SHA256 b71fa85344fdf66330869d2d45b15c89e0c07ef420944c6d67975a85cae3c1fd SHA512 89d31a5a10c7ba21a16534b20faf6532c097c84375d09ce9940593b9e569e538db0e5174b9554e0890fb94b2194852b782e235f20dd9d7d609c08d88ac0bffa2 WHIRLPOOL 2cf0d44f820c6f2a2cda5e52faf48517d85d7a73c59623af657473ee7baeeeae57072c4f0dcba4dbbdbeb386dc01ccf3733bc8b148c53bcbc7252a4ba45d1fa3
diff --git a/sci-visualization/gfsview/gfsview-20111003.ebuild b/sci-visualization/gfsview/gfsview-20111003.ebuild
deleted file mode 100644 (file)
index 3460417..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-DESCRIPTION="Graphical viewer for Gerris simulation files"
-HOMEPAGE="http://gfs.sourceforge.net/"
-SRC_URI="https://dev.gentoo.org/~bicatali/distfiles/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
-
-RDEPEND=">=sci-libs/gerris-${PV}
-       media-libs/ftgl
-       media-libs/mesa[osmesa]
-       x11-libs/gtk+:2
-       >=x11-libs/gtkglext-1.0.6
-       x11-libs/startup-notification"
-
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-
-S="${WORKDIR}"/${P/-20/-snapshot-}
-
-src_configure() {
-       econf $(use_enable static-libs static)
-}
similarity index 67%
rename from sci-visualization/gfsview/gfsview-20120706.ebuild
rename to sci-visualization/gfsview/gfsview-20120706-r1.ebuild
index b848f1b13eb26331032a0bb3e3d418725aa8b033..006784d0901892bcd2b6aee59a6857ee48290e76 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=4
+EAPI=5
 
-inherit autotools-utils
+inherit autotools-utils toolchain-funcs
 
 MYP=${P/-20/-snapshot-}
 
@@ -17,16 +17,20 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
 IUSE="static-libs"
 
-RDEPEND="sci-libs/gerris
+RDEPEND="
+       sci-libs/gerris
        media-libs/ftgl
        media-libs/mesa[osmesa]
        x11-libs/gtk+:2
        >=x11-libs/gtkglext-1.0.6
-       x11-libs/startup-notification"
-
+       x11-libs/startup-notification
+"
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
 S="${WORKDIR}/${MYP}"
 
-export LIBS=-lGL
+src_prepare() {
+       export LIBS="$($(tc-getPKG_CONFIG) --libs gl)"
+       autotools-utils_src_prepare
+}
index bab5e850a77ba7c1fa581b098e3cea116f09cf88..5a84f095853e22248e3c60bef5b1b9dfc3437598 100644 (file)
@@ -1,8 +1,8 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<herd>sci</herd>
-<longdescription lang='en'>
+  <herd>sci</herd>
+  <longdescription lang="en">
   GfsView is a graphical viewer for Gerris simulation files.
 </longdescription>
 </pkgmetadata>