dev-python/python-xlib: 0.26 + EAPI 7 + py38
authorSebastian Pipping <sping@gentoo.org>
Sun, 8 Mar 2020 16:53:36 +0000 (17:53 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sun, 8 Mar 2020 16:56:35 +0000 (17:56 +0100)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.92, Repoman-2.3.20

dev-python/python-xlib/Manifest
dev-python/python-xlib/python-xlib-0.26.ebuild [new file with mode: 0644]

index 97e92621b38a9ff2446e16dab52d8ae19d40d615..efa7e2cfa3420d1019847222c257da14731380a2 100644 (file)
@@ -1,3 +1,4 @@
 DIST python-xlib-0.15rc1.tar.gz 188750 BLAKE2B e35a1904975a6f5bbeb5ab5215f8ffaf87052b51a649c1c25455ef8039d5643e51195a801024b3717df930c486a126f0a055822b15b2f01d207b6a17fe01d5ba SHA512 e27f56e0d76fac534e6754b1e64316636b49859eb6c9ceef5952c8b42cf53bc798a705fa54c283c896324d9a23778beec583cb62984a6a43b024643a70f3fe3a
 DIST python-xlib-0.19.tar.bz2 188359 BLAKE2B ce7555b05ea84c5b74dcaa8457bfd1d8cd73d2c74e5a5a08e984fbe56ddb1036c26ecf669c67434eac31f7ff4aab723c5fe5672114cfa83f4693eb72835558b6 SHA512 070807eed50ce9a17926c36686dac5c143deff0b687a2967afade1a2f776d42ffbea0bbfad3a7480118ba7b1cf5ac0bb64978fdd3ca125c1df651af456dba5be
 DIST python-xlib-0.23.tar.bz2 172744 BLAKE2B 81ded38baaa93da53ffede91f8b0579328e3cdae35b8a3436b8e0651d54c03f4972f3af621e3e17023fa50e57ce90d62cda7b59e459e0d883c8264a513c7d09a SHA512 5e97000e59459cc0e8f21f9c9ee525a064b316e1cbd6d1a5bdaed9edb178ffd124216c27b4a9f365471416e2548b4f7947bf1ebc9f75fe0c2266f37e7134a6c1
+DIST python-xlib-0.26.tar.bz2 207058 BLAKE2B ff9562ca55233bb9ec6fbff19e1e7f4dcd39aa0f497c1aeccc21d50ccdecf8bddb7a6d556679fa133cb1721c7d1ebd41081325739d0f505571928ac74749bc42 SHA512 1f012861e657094323126f6065da4ff743728253625929676fc39ed8d2673e38b9f39f4be8ed2350c6d41a25a184a68489866c9a5edf07c87d62382651e6f884
diff --git a/dev-python/python-xlib/python-xlib-0.26.ebuild b/dev-python/python-xlib/python-xlib-0.26.ebuild
new file mode 100644 (file)
index 0000000..8b9838d
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A fully functional X client library for Python, written in Python"
+HOMEPAGE="https://github.com/python-xlib/python-xlib"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]
+       doc? ( sys-apps/texinfo )"
+
+# DISTUTILS_IN_SOURCE_BUILD=1
+
+distutils_enable_tests unittest
+
+python_compile_all() {
+       use doc && emake -C doc/info
+}
+
+src_test() {
+       virtx distutils-r1_src_test
+}
+
+python_install_all() {
+       use doc && doinfo doc/info/*.info
+       distutils-r1_python_install_all
+}