app-i18n/translate-shell: bump version to 0.9.6.11
authorFerenc Erki <erkiferenc@gmail.com>
Sat, 14 Dec 2019 22:19:48 +0000 (23:19 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 3 Jan 2020 09:14:26 +0000 (11:14 +0200)
Closes: https://bugs.gentoo.org/691626
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Ferenc Erki <erkiferenc@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12627
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-i18n/translate-shell/Manifest
app-i18n/translate-shell/metadata.xml
app-i18n/translate-shell/translate-shell-0.9.6.11.ebuild [new file with mode: 0644]

index c761a3798357d6ad980b36e9fa886ab5d9ee4f6e..b5178e6d272dca853783a9e44c0e603d4ade8e29 100644 (file)
@@ -1 +1,2 @@
 DIST translate-shell-0.9.6.10.tar.gz 76079 BLAKE2B 079e7d1fe039586b580fe4197e00cda2bceb2bcf3bc11eb003bec56f3b4cc19a955182bf7bf50ba6b3f9e2d28bb091b49b98ebb0dfcd06ef25ef5c9929a307cc SHA512 b78f4f982bc65f530186a6728a1976eb96c9f6a70c7bd93e99357ed7016ee4ade0e0415aeca063e513de497cc4b082f7cc247fe7278292f7c3b7dda6af744743
+DIST translate-shell-0.9.6.11.tar.gz 76779 BLAKE2B 39748d0a2d7db504fd4c0bee516f703291dce93f19aa760fdae70b0551cb5f14ae5483314114f7e1141ae2231e0b128a79a9c05ec1fd08c970be886c4430e32d SHA512 d4d376b3750e43e3de5b95790fea7fc91e94140526ac15ee9f7818554f95d410772c8f8887433b6fd4547f569b3d6f510c1bc1497d8237223c344dbb8f0ae87f
index bea3adaede3875899e5f5b39ff78f4e31646c220..8677de75cecd88807c9444ef99953aa61e6892db 100644 (file)
@@ -15,8 +15,8 @@
        </maintainer>
        <longdescription lang="en">
                Translate Shell (formerly Google Translate CLI) is a command-line
-               translator powered by Google Translate (default), Bing Translator, and
-               Yandex.Translate.
+               translator powered by Google Translate (default), Bing Translator,
+               Yandex.Translate and Apertium.
        </longdescription>
        <use>
                <flag name="tts">Enable text-to-speech support</flag>
diff --git a/app-i18n/translate-shell/translate-shell-0.9.6.11.ebuild b/app-i18n/translate-shell/translate-shell-0.9.6.11.ebuild
new file mode 100644 (file)
index 0000000..833f76c
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Online command-line translator"
+HOMEPAGE="https://www.soimort.org/translate-shell/"
+SRC_URI="https://github.com/soimort/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/gawk"
+DEPEND="${RDEPEND}
+       test? (
+               app-editors/emacs
+               app-misc/rlwrap
+       )"
+
+src_test() {
+       emake NETWORK_ACCESS=no test
+}
+
+src_install() {
+       emake PREFIX="${D}/usr" install
+}
+
+pkg_postinst() {
+       elog "You may need to install the following optional packages for full functionality:"
+       optfeature "Support all built-in translators (e.g. Apertium, Yandex)" net-misc/curl[ssl]
+       optfeature "Display text in right-to-left scripts" dev-libs/fribidi
+       optfeature "Text-to-speech functionality" media-sound/mpg123 app-accessibility/espeak media-video/mpv media-video/mplayer
+       optfeature "Interactive translation (REPL)" app-editors/emacs app-misc/rlwrap
+       optfeature "Spell checking" app-text/aspell app-text/hunspell
+}