dev-python/boto-2.49.0-r1: revbump, modernize a bit, py38
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 29 Apr 2020 17:27:57 +0000 (10:27 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 29 Apr 2020 17:33:14 +0000 (10:33 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/boto/boto-2.49.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/boto/boto-2.49.0-r1.ebuild b/dev-python/boto/boto-2.49.0-r1.ebuild
new file mode 100644 (file)
index 0000000..7bc0f11
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto https://pypi.org/project/boto/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+BDEPEND="
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="!test? ( test )"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT+=" test"
+
+python_test() {
+       "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
+}