Version bump
authorMichael Cummings <mcummings@gentoo.org>
Mon, 16 Apr 2007 10:56:41 +0000 (10:56 +0000)
committerMichael Cummings <mcummings@gentoo.org>
Mon, 16 Apr 2007 10:56:41 +0000 (10:56 +0000)
Package-Manager: portage-2.1.2.3

perl-core/Math-BigInt/ChangeLog
perl-core/Math-BigInt/Math-BigInt-1.82.ebuild [new file with mode: 0644]
perl-core/Math-BigInt/files/digest-Math-BigInt-1.82 [new file with mode: 0644]
perl-core/Math-BigRat/ChangeLog
perl-core/Math-BigRat/Math-BigRat-0.18.ebuild [new file with mode: 0644]
perl-core/Math-BigRat/files/digest-Math-BigRat-0.18 [new file with mode: 0644]
perl-core/bignum/ChangeLog
perl-core/bignum/bignum-0.20.ebuild [new file with mode: 0644]
perl-core/bignum/files/digest-bignum-0.20 [new file with mode: 0644]

index e49920660ab7d63676ab76369c85c5c4d1de40de..3c632bb685d6673c058ab17a71860f0f591c3392 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for perl-core/Math-BigInt
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/ChangeLog,v 1.30 2007/04/11 03:04:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/ChangeLog,v 1.31 2007/04/16 10:56:12 mcummings Exp $
+
+*Math-BigInt-1.82 (16 Apr 2007)
+
+  16 Apr 2007; Michael Cummings <mcummings@gentoo.org>
+  +Math-BigInt-1.82.ebuild:
+  Version bump
 
   11 Apr 2007; Jeroen Roovers <jer@gentoo.org> Math-BigInt-1.81-r1.ebuild:
   Marked ~hppa (bug #173295).
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.82.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.82.ebuild
new file mode 100644 (file)
index 0000000..8b7bc6c
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/Math-BigInt-1.82.ebuild,v 1.1 2007/04/16 10:56:12 mcummings Exp $
+
+inherit perl-module eutils
+
+DESCRIPTION="Arbitrary size floating point math package"
+HOMEPAGE="http://serach.cpan.org/~tels/"
+SRC_URI="mirror://cpan/authors/id/T/TE/TELS/math/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+               >=virtual/perl-Scalar-List-Utils-1.14"
+
+PDEPEND="perl-core/bignum
+               perl-core/Math-BigRat"
+
+SRC_TEST="do"
+PREFER_BUILDPL="no"
diff --git a/perl-core/Math-BigInt/files/digest-Math-BigInt-1.82 b/perl-core/Math-BigInt/files/digest-Math-BigInt-1.82
new file mode 100644 (file)
index 0000000..e274461
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 91b98b819a9e56c5feb5f8d1dfeb5b4c Math-BigInt-1.82.tar.gz 187505
+RMD160 1cd2c165da91d4668171c4e78d90851f6afdd9be Math-BigInt-1.82.tar.gz 187505
+SHA256 820ccf9832a6e7916f42255a8da6767441900b93a0c1ce824a3e4decb297f38f Math-BigInt-1.82.tar.gz 187505
index bcad6e7510ec472ab27b284d5ae76772495b5cb6..6bfd466c7b47e09d919f3e909fa72c2daf3889fd 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for perl-core/Math-BigRat
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigRat/ChangeLog,v 1.6 2007/04/11 03:04:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigRat/ChangeLog,v 1.7 2007/04/16 10:55:36 mcummings Exp $
+
+*Math-BigRat-0.18 (16 Apr 2007)
+
+  16 Apr 2007; Michael Cummings <mcummings@gentoo.org>
+  +Math-BigRat-0.18.ebuild:
+  Version bump
 
   11 Apr 2007; Jeroen Roovers <jer@gentoo.org> Math-BigRat-0.17.ebuild:
   Marked ~hppa (bug #173295).
diff --git a/perl-core/Math-BigRat/Math-BigRat-0.18.ebuild b/perl-core/Math-BigRat/Math-BigRat-0.18.ebuild
new file mode 100644 (file)
index 0000000..87e861e
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigRat/Math-BigRat-0.18.ebuild,v 1.1 2007/04/16 10:55:36 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="Arbitrary big rational numbers"
+HOMEPAGE="http://search.cpan.org/~tels"
+SRC_URI="mirror://cpan/authors/id/T/TE/TELS/math/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+PREFER_BUILDPL="no"
+
+DEPEND=">=perl-core/Math-BigInt-1.79
+       dev-lang/perl"
diff --git a/perl-core/Math-BigRat/files/digest-Math-BigRat-0.18 b/perl-core/Math-BigRat/files/digest-Math-BigRat-0.18
new file mode 100644 (file)
index 0000000..30731b9
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b412ab0e16fbc6ef3916b8cfa9996dfc Math-BigRat-0.18.tar.gz 46073
+RMD160 9c1f9f206012875a647f3180e158f68a78e40b20 Math-BigRat-0.18.tar.gz 46073
+SHA256 66e629347a26fc7584bbf10d6509a3f2f3e6243ad849f7383dcb9e0606e50840 Math-BigRat-0.18.tar.gz 46073
index bfa4caeb2be253c915c33a610915b89b2e2103bf..a4b8a588a109cac4fb2ec732be852e4ecd3e6cc5 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for perl-core/bignum
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/bignum/ChangeLog,v 1.6 2007/04/11 03:04:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/bignum/ChangeLog,v 1.7 2007/04/16 10:56:41 mcummings Exp $
+
+*bignum-0.20 (16 Apr 2007)
+
+  16 Apr 2007; Michael Cummings <mcummings@gentoo.org> +bignum-0.20.ebuild:
+  Version bump
 
   11 Apr 2007; Jeroen Roovers <jer@gentoo.org> bignum-0.19.ebuild:
   Marked ~hppa (bug #173295).
diff --git a/perl-core/bignum/bignum-0.20.ebuild b/perl-core/bignum/bignum-0.20.ebuild
new file mode 100644 (file)
index 0000000..13c4af8
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/bignum/bignum-0.20.ebuild,v 1.1 2007/04/16 10:56:41 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="Transparent BigNumber/BigRational support for Perl"
+HOMEPAGE="http://search.cpan.org/~tels"
+SRC_URI="mirror://cpan/authors/id/T/TE/TELS/math/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+PREFER_BUILDPL="no"
+
+DEPEND=">=perl-core/Math-BigInt-1.82
+       >=perl-core/Math-BigRat-0.18
+       test? ( >=dev-perl/Test-Pod-Coverage-1.08 )
+       dev-lang/perl"
diff --git a/perl-core/bignum/files/digest-bignum-0.20 b/perl-core/bignum/files/digest-bignum-0.20
new file mode 100644 (file)
index 0000000..945b8a2
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ecc137561eff4b8f00c6464aca4bb6f6 bignum-0.20.tar.gz 27009
+RMD160 c7cd2259d9759c978d5fc5c379a6f8a06c448193 bignum-0.20.tar.gz 27009
+SHA256 51792f57a27bec0cab9fbd8e6d54a21735107062e670d84d27c1f0ddbfd49cc9 bignum-0.20.tar.gz 27009