dev-python/decorator: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 20:22:06 +0000 (21:22 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 20:34:43 +0000 (21:34 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/decorator/Manifest
dev-python/decorator/decorator-4.3.2.ebuild [deleted file]
dev-python/decorator/decorator-4.4.0.ebuild [deleted file]

index 1f837e53524919f73b085621dd4869b51c050f57..2d25674b3788c30a298f3b4f3788f343f8906667 100644 (file)
@@ -1,4 +1,2 @@
-DIST decorator-4.3.2.tar.gz 34892 BLAKE2B 49485ec0ae25947b27dbc23c8f17194bf5b03778e7e43524e561c320487e1b6830a1ab39e9fba2a154e1cd00155af779965e497724f01d81d301a0ca979ba058 SHA512 87102e1b314086d008c48bf53f1061b28fdbd3ccd3d301773102fd43e3a4ce8b5ffeb9107fb5d5f47b7bd45c26e5b3b2913ea20745ffc9b274e2c0b24a69ef70
-DIST decorator-4.4.0.tar.gz 34559 BLAKE2B ed8cad0081ca47cef15f30d10afda1d19dd496f482a4621a1a349d0b5fa63d41ea4daee389d21b8b176be09949f8519c117a448003b2e8ee5f5c2d50d3015cac SHA512 32c35c80581cb7fd0b2461d21c7eb14190294b2ccc9f92749b6bc74449f7d02a26281e9a2817f6f16871a6cddb7b02b8fae8119c22256fe43a6aaa31a7599dd5
 DIST decorator-4.4.1.tar.gz 33350 BLAKE2B 75544aeb6dd995edc091515da70f4bfff8a12a02442b47c945d4ab18e90eb48647cdc86540de542ff3357cb2114eebdefead7edeeba25587a15fb1e7c87519c6 SHA512 12378702246b212d5fe0153dc97cafdb2afd4779c51fd224385e3c3562e1a1e3439574aa7c37c8521fe5f86a5f0b4d4b3075e0407cc249f8fa4b341e1ebe06e0
 DIST decorator-4.4.2.tar.gz 33629 BLAKE2B 5b2c6a1b6aba293d4b93444d4613e3c9af16bd9d6d80ae9eb21112a4a16397ff67e1f648e8118beeb7d17755a2f1bd37b867f73129c42ef7f8654d1c1f609e5f SHA512 c068efd4e70764ac447b772c9c29625c2180dad256b2b4e46a50a8479fc1d7de09b114c2ba11bb37dd58774ed9460d2e0ea9fa76061833a2d3c2676ac91a0db1
diff --git a/dev-python/decorator/decorator-4.3.2.ebuild b/dev-python/decorator/decorator-4.3.2.ebuild
deleted file mode 100644 (file)
index dd896da..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simplifies the usage of decorators for the average programmer"
-HOMEPAGE="https://github.com/micheles/decorator https://pypi.org/project/decorator/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DOCS=( README.rst )
-
-python_test() {
-       "${PYTHON}" src/tests/test.py || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/decorator/decorator-4.4.0.ebuild b/dev-python/decorator/decorator-4.4.0.ebuild
deleted file mode 100644 (file)
index fd5910c..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simplifies the usage of decorators for the average programmer"
-HOMEPAGE="https://github.com/micheles/decorator https://pypi.org/project/decorator/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DOCS=( CHANGES.md )
-
-python_test() {
-       esetup.py test
-}