dev-python/livereload: Replace distutils-r1 EXAMPLES use
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:34 +0000 (10:56 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:34 +0000 (10:56 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/livereload/livereload-2.4.1.ebuild
dev-python/livereload/livereload-2.5.2.ebuild

index e79f6070944f53177a50b57abdbb533d3bd0ffb0..f0ee8033d667b13bd9fc1b73bd26762d1c6b668a 100644 (file)
@@ -33,7 +33,11 @@ python_test() {
 }
 
 python_install_all() {
-       use examples && local EXAMPLES=( example/. )
+       if use examples; then
+               docinto examples
+               dodoc -r example/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
 
        distutils-r1_python_install_all
 }
index eb41b161761316c069504ee71e90f205acfc1e03..487fd52dd92b4ece8fd50ae7a22fa581c1ccddcb 100644 (file)
@@ -33,7 +33,11 @@ python_test() {
 }
 
 python_install_all() {
-       use examples && local EXAMPLES=( example/. )
+       if use examples; then
+               docinto examples
+               dodoc -r example/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
 
        distutils-r1_python_install_all
 }