dev-libs/utfcpp: Add live ebuild.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Fri, 9 Aug 2019 16:22:31 +0000 (16:22 +0000)
committerMike Gilbert <floppym@gentoo.org>
Fri, 9 Aug 2019 18:38:58 +0000 (14:38 -0400)
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-libs/utfcpp/utfcpp-9999.ebuild [new file with mode: 0644]

diff --git a/dev-libs/utfcpp/utfcpp-9999.ebuild b/dev-libs/utfcpp/utfcpp-9999.ebuild
new file mode 100644 (file)
index 0000000..028e8ae
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 2015-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+       inherit git-r3
+
+       EGIT_REPO_URI="https://github.com/nemtrif/utfcpp"
+       EGIT_SUBMODULES=()
+fi
+
+DESCRIPTION="UTF-8 C++ library"
+HOMEPAGE="https://github.com/nemtrif/utfcpp"
+if [[ "${PV}" == "9999" ]]; then
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/nemtrif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+BDEPEND=""
+DEPEND="test? ( dev-cpp/gtest )"
+RDEPEND=""
+
+src_prepare() {
+       sed -e "/add_subdirectory(extern\/gtest)/d" -i CMakeLists.txt || die
+       sed -e "s/gtest_main/gtest &/" -i tests/CMakeLists.txt || die
+
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DUTF8_SAMPLES=OFF
+               -DUTF8_TESTS=$(usex test ON OFF)
+       )
+
+       cmake-utils_src_configure
+}