sci-libs/suitesparseconfig: new version 5.4.0.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 29 Feb 2020 01:36:35 +0000 (20:36 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Mon, 2 Mar 2020 17:20:42 +0000 (12:20 -0500)
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is
part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey
whose sage-on-gentoo ebuilds I'm using. There's a newer release
(v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
sci-libs/suitesparseconfig/Manifest
sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild [new file with mode: 0644]

index 3bb36d978e7a05c1752d9ccd5fe31b4cd7eef29c..ea9fb1eba34d16d15c174b38875d07d708f0fe24 100644 (file)
@@ -1 +1,2 @@
 DIST suitesparseconfig-4.2.1.tar.bz2 256308 BLAKE2B 74993d9a43117e9b71e21856c7b27d4aa6627c64a4235d7d37efa282a0a8e54fa8c6d6aea1cd447902ab8b18bfff1aa1e0d67a6b86d86c2feaf6a9f716ac2f0f SHA512 2363f8adb962d1f932b4390ac54e7203b5eec6005f9275dc155a4b178fd5259ddd42dc34c663a4c82546452c0f1e05619522567a69be1a58efc5d032b6d7a61d
+DIST suitesparseconfig-5.4.0.tar.bz2 257352 BLAKE2B 3832e34281c742a7d704dde866c53c742420486d782075e047b605fb2062d77353cda8670138c4bef62c73d16e123a8a74f65272a01766f124c1e53f9ba32e9d SHA512 e91f60f426b73add473c6341e30512b8fbe65b7850cd83f3852e78f1e74ce067b7ae1577ccc795698e680a841a9d32c2ca073651a4fe95f0b723578721aec874
diff --git a/sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild b/sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild
new file mode 100644 (file)
index 0000000..6e48d59
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Common configurations for all packages in suitesparse"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+# Upstream says, "no licensing restrictions apply to this file or to the
+# SuiteSparse_config directory".
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" \
+               econf \
+               $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+       if ! use static-libs; then
+               find "${ED}" -name "*.la" -delete || die
+       fi
+}