sys-kernel/vanilla-kernel: Bump to 4.19.94 LTS
authorMichał Górny <mgorny@gentoo.org>
Sun, 5 Jan 2020 13:19:36 +0000 (14:19 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 9 Jan 2020 16:10:19 +0000 (17:10 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-kernel/vanilla-kernel/Manifest
sys-kernel/vanilla-kernel/vanilla-kernel-4.19.94.ebuild [new file with mode: 0644]

index 26dcb4ed4d0c50ca730ee68b0e1628f7e5966312..5780431307e03988bf607e672ab1183c837de62c 100644 (file)
@@ -1,3 +1,6 @@
+DIST linux-4.19.85-arch1.i686.config 222183 BLAKE2B 03eac77940db0ee6b4f2a006edc600ef34141bbca849f5be4de9b961301a8fc987da6d0e21344aa5d80c29bb7793d56cf5441abb6c8e4057d94e2601c174c1be SHA512 6bd45c9dfd96b1afb8c1ca1ca72722baee6c91894e454d7af937de02242d3bb9d3b6870f5976aa96245c753c6bc1ac637a6356125b0d4c596aadef643b8c3d8d
+DIST linux-4.19.92-arch1.amd64.config 222487 BLAKE2B a658d80d85525287a1df9053ca2ddfe423ab423bcc3b9ea8bd9cda65cc7ffa4b1be782c48c867c13e46070af4016f446860f5cf71351f239da1eff6c45a5aa6a SHA512 a5658c8e8464516dffd6f624344e739784cb315d334b2c5105bd5d16022b6366ad4ec00d3692a7b78e2458514175522bc85e834bf19593feff6363b616860258
+DIST linux-4.19.94.tar.xz 103389152 BLAKE2B 291db6f448606a4ba288295b4b1c0b813e736534e4749a152baa1d07fcf52bba2b59e7b4b261594a2deb9ad961afec50a28b4ec126f97033f1c0a36aba9f2961 SHA512 c6017e854ec06054c658042c2e8227d79284ecdadf0a2e1c5da799ca2ac165a266e7d33aa52361d0036ddb3059e3b24f0a68b45ffd84d87394d3f41492f6f9a4
 DIST linux-5.4.10.tar.xz 109453652 BLAKE2B 88706cfc05ec1cc201f08e069dc6ad4f8e6fb49dbef5937208ba1e752e18b46639a5d32d4d0e270a0f2f6ed872aed70beeb2b0367d41fe443437331902a90bb2 SHA512 6328ad7e18b6fa982415b0de75e3384f58ce8428bd8c212871a31f3885a0819d241138d384b2e6d1b74a1d260229a027f9c1674a65f5b6c48e6b25e3024a0974
 DIST linux-5.4.3-arch1.i686.config 241295 BLAKE2B 795b6286bd1e7dc6aa5c1428e7bf08c204ce6c8cbee57863e9f64f8990790cc4398a7d062b54c89b1b80640f02a40fce028d9397725db0f968e8028b0611a20f SHA512 8c7387ded21c02b9cffee0e6d61a7040c44deae21764f743f7719f0d1c7adf684f6b62a501fe31709787ba741859e55fc3b8a3d3d27e52c09f2d8604212bf0a7
 DIST linux-5.4.7.arch1-1.amd64.config 241598 BLAKE2B 536cce5cc23cf20e71cba7468a125557f85d8ffc3cb194dced79bd489d39f2e4ed3960816d15d1491007d11b3af466e0a74267f983dfcc5f511f9f566f7e9821 SHA512 8658db603e180c75caf76972d85ecf8a4e9c9cf6e047b4f9fc7cba0fa426f434361528c1c29b5580f116cdd23091bf9afb6635d751f3b90c4e968d16db90eac1
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.94.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.94.ebuild
new file mode 100644 (file)
index 0000000..18607be
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-build
+
+MY_P=linux-${PV}
+AMD64_CONFIG_VER=4.19.92-arch1
+AMD64_CONFIG_HASH=bf97de6a2e405659aaad4c251b7f0bb48d5ed3c9
+I686_CONFIG_VER=4.19.85-arch1
+I686_CONFIG_HASH=1f0345e2983d2edd55b401cb5a87fdf365a4192c
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+       amd64? (
+               https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux-lts&id=${AMD64_CONFIG_HASH}
+                       -> linux-${AMD64_CONFIG_VER}.amd64.config
+       )
+       x86? (
+               https://git.archlinux32.org/packages/plain/core/linux-lts/config?id=${I686_CONFIG_HASH}
+                       -> linux-${I686_CONFIG_VER}.i686.config
+       )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       !sys-kernel/vanilla-kernel-bin:${SLOT}"
+
+pkg_pretend() {
+       mount-boot_pkg_pretend
+
+       ewarn "This is an experimental package.  The built kernel and/or initramfs"
+       ewarn "may not work at all or fail with your bootloader configuration.  Please"
+       ewarn "make sure to keep a backup kernel available before testing it."
+}
+
+src_prepare() {
+       default
+
+       # prepare the default config
+       case ${ARCH} in
+               amd64)
+                       cp "${DISTDIR}"/linux-${AMD64_CONFIG_VER}.amd64.config .config || die
+                       ;;
+               x86)
+                       cp "${DISTDIR}"/linux-${I686_CONFIG_VER}.i686.config .config || die
+                       ;;
+               *)
+                       die "Unsupported arch ${ARCH}"
+                       ;;
+       esac
+
+       local config_tweaks=(
+               # shove arch under the carpet!
+               -e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
+               # we do support x32
+               -e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
+               # disable signatures
+               -e '/CONFIG_MODULE_SIG/d'
+               -e '/CONFIG_SECURITY_LOCKDOWN/d'
+               # disable compression to allow stripping
+               -e '/CONFIG_MODULE_COMPRESS/d'
+               # disable gcc plugins to unbreak distcc
+               -e '/CONFIG_GCC_PLUGIN_STRUCTLEAK/d'
+       )
+       sed -i "${config_tweaks[@]}" .config || die
+}