x11-misc/cairo-clock: EAPI bump 4 -> 6, fix #452106
authorHarri Nieminen <moikkis@gmail.com>
Mon, 27 Feb 2017 09:21:58 +0000 (11:21 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 1 Mar 2017 20:43:16 +0000 (21:43 +0100)
Gentoo-Bug: https://bugs.gentoo.org/452106

Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/4091

x11-misc/cairo-clock/cairo-clock-0.3.3.ebuild
x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild [moved from x11-misc/cairo-clock/cairo-clock-0.3.4.ebuild with 66% similarity]
x11-misc/cairo-clock/files/cairo-clock-0.3.4-desktop.patch [new file with mode: 0644]
x11-misc/cairo-clock/files/cairo-clock-0.3.4-linker.patch [new file with mode: 0644]

index e2471b3ae89a46725b830468316f73d94039e9bf..c4609d99d9c302ddb030fb77052aab5ea27f0c1f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=2
@@ -6,7 +6,7 @@ EAPI=2
 inherit autotools base
 
 DESCRIPTION="An analog clock displaying the system-time"
-HOMEPAGE="http://macslow.thepimp.net/?page_id=23"
+HOMEPAGE="https://launchpad.net/cairo-clock"
 SRC_URI="http://macslow.thepimp.net/projects/${PN}/${PN}_${PV}-1.tar.gz"
 
 LICENSE="GPL-2"
similarity index 66%
rename from x11-misc/cairo-clock/cairo-clock-0.3.4.ebuild
rename to x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild
index 786624c702da4a0e4facb4d7a50ef5b222af4828..beeae3cafbb2ea59ea071eb48b3586e4f6bbce63 100644 (file)
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=6
+
+inherit autotools
 
 DESCRIPTION="An analog clock displaying the system-time"
-HOMEPAGE="http://macslow.net/?page_id=23"
+HOMEPAGE="https://launchpad.net/cairo-clock"
 SRC_URI="http://macslow.thepimp.net/projects/${PN}/${P}.tar.gz"
 
 LICENSE="GPL-2"
@@ -23,9 +25,12 @@ DEPEND="${DEPEND}
        virtual/pkgconfig
        sys-devel/gettext"
 
-DOCS=( AUTHORS NEWS README TODO )
+PATCHES=(
+       "${FILESDIR}"/${P}-desktop.patch
+       "${FILESDIR}"/${P}-linker.patch
+)
 
 src_prepare() {
-       # cc: error: unrecognized option '--export-dynamic'
-       sed -i -e '/cairo_clock_LDFLAGS/s:=.*:= -rdynamic:' src/Makefile.in || die
+       default
+       eautoreconf
 }
diff --git a/x11-misc/cairo-clock/files/cairo-clock-0.3.4-desktop.patch b/x11-misc/cairo-clock/files/cairo-clock-0.3.4-desktop.patch
new file mode 100644 (file)
index 0000000..5228776
--- /dev/null
@@ -0,0 +1,18 @@
+diff -u desktop/cairo-clock.desktop desktop2/cairo-clock.desktop
+--- a/desktop/cairo-clock.desktop
++++ b/desktop/cairo-clock.desktop
+@@ -37,4 +37,4 @@
+ Comment[zh_TW]=一個超好用的類比時鐘
+ Exec=cairo-clock
+ Icon=cairo-clock
+-Categories=GNOME;Application;Utility;
++Categories=GNOME;Utility;
+diff -u desktop/cairo-clock.desktop.in desktop2/cairo-clock.desktop.in
+--- a/desktop/cairo-clock.desktop.in
++++ b/desktop/cairo-clock.desktop.in
+@@ -5,4 +5,4 @@
+ _Comment=a super fine analog clock
+ Exec=cairo-clock
+ Icon=cairo-clock
+-Categories=GNOME;Application;Utility;
++Categories=GNOME;Utility;
diff --git a/x11-misc/cairo-clock/files/cairo-clock-0.3.4-linker.patch b/x11-misc/cairo-clock/files/cairo-clock-0.3.4-linker.patch
new file mode 100644 (file)
index 0000000..bdd1a7b
--- /dev/null
@@ -0,0 +1,22 @@
+From 9e1575324da26ef15143ab2dd38f61af222576b4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Mirco=20M=C3=BCller?= <macslow@gmail.com>
+Date: Thu, 9 Feb 2017 01:02:03 +0100
+Subject: [PATCH] Updated linker-options so ld is happy.
+
+---
+ src/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 7057198..fd88852 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,7 +1,7 @@
+ bin_PROGRAMS = cairo_clock
+ transform = s/_/-/g
+-cairo_clock_LDFLAGS = -Wl, --export-dynamic
++cairo_clock_LDFLAGS = -Wl,-export-dynamic
+ cairo_clock_LDADD =   \
+       $(GLIB_LIBS)    \