use games_get_libdir
authorTristan Heaven <tristan@gentoo.org>
Mon, 9 Apr 2007 17:39:11 +0000 (17:39 +0000)
committerTristan Heaven <tristan@gentoo.org>
Mon, 9 Apr 2007 17:39:11 +0000 (17:39 +0000)
Package-Manager: portage-2.1.2.3

games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild
games-emulation/psemu-spunull/psemu-spunull-1.0.ebuild
games-emulation/xe/xe-20060101.ebuild
games-emulation/xmame/xmame-0.106.ebuild
games-emulation/xmess/xmess-0.106.ebuild

index 52cdbaeb0f466f194e2e018b9427f9f5df7568b7..2325d2b01bc05505a6db7463f3611ffe2d80a6fe 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild,v 1.2 2006/12/06 17:18:11 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopsspu/psemu-peopsspu-1.0.9.ebuild,v 1.3 2007/04/09 17:26:23 nyhm Exp $
 
-inherit eutils games
+inherit autotools eutils games
 
 DESCRIPTION="P.E.Op.S Sound Emulation (SPU) PSEmu Plugin"
 HOMEPAGE="http://sourceforge.net/projects/peops/"
@@ -19,7 +19,7 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
 DEPEND="${RDEPEND}
        sys-devel/automake"
 
-S="${WORKDIR}"
+S=${WORKDIR}
 
 src_unpack() {
        unpack ${A}
@@ -31,22 +31,22 @@ src_unpack() {
                || die "sed Makefile failed"
 
        cd linuxcfg
-       tar -zxf spucfg.tar.gz || die "unpack linuxcfg"
-       make maintainer-clean || die "distclean linuxcfg"
+       unpack ./spucfg.tar.gz
+       emake maintainer-clean || die "distclean linuxcfg"
        rm -f {,src/}Makefile.in aclocal.m4 configure
-       edos2unix `find -name '*.[ch]'` *.in
-       aclocal && automake -a -c && autoconf || die "could not autotool"
+       edos2unix $(find -name '*.[ch]') *.in
+       eautoreconf
 }
 
 src_compile() {
        cd src
        if use oss || ! use alsa; then
-               make clean || die "oss clean"
+               emake clean || die "oss clean"
                emake USEALSA=FALSE || die "oss build"
                mv libspu* ..
        fi
        if use alsa ; then
-               make clean || die "alsa clean"
+               emake clean || die "alsa clean"
                emake USEALSA=TRUE || die "alsa build"
                mv libspu* ..
        fi
@@ -58,12 +58,12 @@ src_compile() {
 }
 
 src_install() {
-       exeinto ${GAMES_LIBDIR}/psemu/plugins
+       exeinto "$(games_get_libdir)"/psemu/plugins
        doexe libspu* || die "doexe plugins"
-       exeinto ${GAMES_LIBDIR}/psemu/cfg
+       exeinto "$(games_get_libdir)"/psemu/cfg
        doexe cfgPeopsOSS || die "doexe cfg"
-       insinto ${GAMES_LIBDIR}/psemu/cfg
-       doins spuPeopsOSS.cfg
+       insinto "$(games_get_libdir)"/psemu/cfg
+       doins spuPeopsOSS.cfg || die "doins failed"
        dodoc src/*.txt *.txt
        prepgamesdirs
 }
index b35d448559cb5f6c1dbaafecce0fa0b8218c6a21..eb6460c9acfac51f798963821c53526c5f03994a 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-spunull/psemu-spunull-1.0.ebuild,v 1.4 2004/06/24 22:35:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-spunull/psemu-spunull-1.0.ebuild,v 1.5 2007/04/09 17:28:43 nyhm Exp $
 
 inherit eutils games
 
@@ -13,11 +13,11 @@ SLOT="0"
 KEYWORDS="x86"
 IUSE=""
 
-S="${WORKDIR}"
+S=${WORKDIR}
 
 src_unpack() {
        unpack ${A}
-       epatch "${FILESDIR}/${PV}-makefile-cflags.patch"
+       epatch "${FILESDIR}"/${PV}-makefile-cflags.patch
 }
 
 src_compile() {
@@ -28,7 +28,7 @@ src_compile() {
 src_install() {
        dodoc ReadMe.txt
        cd src
-       exeinto "${GAMES_LIBDIR}/psemu/plugins"
-       doexe libspunull-*
+       exeinto "$(games_get_libdir)"/psemu/plugins
+       doexe libspunull-* || die "doexe failed"
        prepgamesdirs
 }
index e4338ab6b24bd59d79e9a222e6e191a17da6ce8e..1048db9a0f9993540e05cb06ec4fc949909d471d 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xe/xe-20060101.ebuild,v 1.4 2006/12/01 21:47:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xe/xe-20060101.ebuild,v 1.5 2007/04/09 17:32:22 nyhm Exp $
 
 inherit games
 
@@ -36,13 +36,13 @@ src_unpack() {
 
 src_install() {
        newgamesbin xe xe.bin || die "newgamesbin failed"
-       newgamesbin "${FILESDIR}/xe-${PV}" xe || die "newgamesbin failed"
+       newgamesbin "${FILESDIR}"/xe-${PV} xe || die "newgamesbin failed"
        sed -i \
-               -e "s:GENTOODIR:${GAMES_LIBDIR}/${PN}:" "${D}/${GAMES_BINDIR}/xe" \
+               -e "s:GENTOODIR:$(games_get_libdir)/${PN}:" "${D}/${GAMES_BINDIR}/xe" \
                || die "sed failed"
-       insinto "${GAMES_LIBDIR}/${PN}"
+       insinto "$(games_get_libdir)"/${PN}
        doins -r modules/ rc/ manual/ || die "doins failed"
-       keepdir "${GAMES_LIBDIR}/${PN}/bios"
+       keepdir "$(games_get_libdir)"/${PN}/bios
        dodoc README.txt
        prepgamesdirs
 }
index 5112fedbbc35fab22be82a65e8279630f8519e60..ff4934daeb28559773a1a2509a6d32c15473acfe 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.106.ebuild,v 1.6 2007/03/12 14:05:45 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.106.ebuild,v 1.7 2007/04/09 17:34:26 nyhm Exp $
 
 inherit flag-o-matic toolchain-funcs eutils games
 
@@ -194,7 +194,7 @@ src_install() {
        if [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
                make DISPLAY_METHOD=x11 install || die "install failed (x11)"
        fi
-       exeinto "${GAMES_LIBDIR}/${PN}"
+       exeinto "$(games_get_libdir)/${PN}"
        for f in $utils
        do
                if [[ -f "${D}${GAMES_BINDIR}"/$f ]] ; then
@@ -232,5 +232,5 @@ pkg_postinst() {
        #useq ggi    && elog " ${TARGET}.ggi"
        useq svga   && elog " ${TARGET}.svgalib"
 
-       elog "Helper utilities are located in ${GAMES_LIBDIR}/${PN}."
+       elog "Helper utilities are located in $(games_get_libdir)/${PN}."
 }
index cf6ffdaf0f7aea05caa61bc494086e287f8696ce..336fff0dcd8b88c3324e6c5691caccee1ddfccf8 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.7 2007/03/12 14:07:09 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.8 2007/04/09 17:39:11 nyhm Exp $
 
 inherit flag-o-matic toolchain-funcs eutils games
 
@@ -194,7 +194,7 @@ src_install() {
        if [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
                make DISPLAY_METHOD=x11 install || die "install failed (x11)"
        fi
-       exeinto "${GAMES_LIBDIR}/${PN}"
+       exeinto "$(games_get_libdir)/${PN}"
        for f in $utils
        do
                if [[ -f "${D}${GAMES_BINDIR}"/$f ]] ; then
@@ -232,5 +232,5 @@ pkg_postinst() {
        #useq ggi    && elog " ${TARGET}.ggi"
        useq svga   && elog " ${TARGET}.svgalib"
 
-       elog "Helper utilities are located in ${GAMES_LIBDIR}/${PN}."
+       elog "Helper utilities are located in $(games_get_libdir)/${PN}."
 }