dev-python/pygit2: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Fri, 5 Jan 2018 22:10:59 +0000 (23:10 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jan 2018 23:19:11 +0000 (00:19 +0100)
dev-python/pygit2/Manifest
dev-python/pygit2/files/pygit2-0.25.1-cffi-1.10.patch [deleted file]
dev-python/pygit2/pygit2-0.25.1.ebuild [deleted file]

index d612c14e31f4db62b3dd0cfe53a70a5dc33af612..544d6a639167c18b0e6a9fab11ab6988e6ce1eed 100644 (file)
@@ -1,2 +1 @@
-DIST pygit2-0.25.1.tar.gz 456580 BLAKE2B b7a9ce90076f2475df41f2e5ee8cbf7cb2ca68553076ae05cb2e8bdd68067f7373e33dfb03cadf90b7f410b5d5989b902b545fddbb1e3a9f17eb17d50692e982 SHA512 19908c874d5c2469609a54893f37367480d27ff03583c38b474ebb125dc9db95dc60776a120bb05662938d6eb62d4bcef24f684688e97e3453ccc27e015736cd
 DIST pygit2-0.26.3.tar.gz 462080 BLAKE2B b3c4b9b8a6aeba22a70a8d2ef1393dace3a065a3625ee3574058e333bca4ba1d60223939f412eecf5ae9d93a81fb81c4a536af46aa047c2c82a48bd81afe4cf9 SHA512 6f727686221d4e8c348f836b7ad278b48a4b971a121b9953c2cf7163bf093936d838aaf83e9edb8628757624ab27e8345a2fb29eb1a79a30e06c0ab0a77e4cc6
diff --git a/dev-python/pygit2/files/pygit2-0.25.1-cffi-1.10.patch b/dev-python/pygit2/files/pygit2-0.25.1-cffi-1.10.patch
deleted file mode 100644 (file)
index c071f9e..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-From b88dc868423af2f760f649960112efd0e37e5335 Mon Sep 17 00:00:00 2001
-From: Lukas Fleischer <lfleischer@lfos.de>
-Date: Sat, 6 May 2017 21:39:33 +0200
-Subject: [PATCH] Fix parameter passing of describe patterns
-
-When ffi.new() is used to build a new pointer object, the returned
-pointer object has ownership on the allocated memory. When it is
-garbage-collected, then the memory is freed. Thus, we need to make sure
-the original object survives its use, otherwise the casted pointer will
-point to garbage.
-
-This fixes one test which was failing with the latest CFFI version, see
-issue #694. Thus, this commit also reverts 803b1cb (cffi 1.10 not yet
-supported, 2017-03-22) where the latest CFFI version was marked as
-unsupported.
-
-Signed-off-by: Lukas Fleischer <lfleischer@lfos.de>
----
- .travis.yml          | 2 +-
- pygit2/repository.py | 6 +++++-
- setup.py             | 4 ++--
- 3 files changed, 8 insertions(+), 4 deletions(-)
-
-diff --git a/pygit2/repository.py b/pygit2/repository.py
-index 9377aa2..472f4ff 100644
---- a/pygit2/repository.py
-+++ b/pygit2/repository.py
-@@ -692,7 +692,11 @@ def describe(self, committish=None, max_candidates_tags=None,
-         if describe_strategy is not None:
-             options.describe_strategy = describe_strategy
-         if pattern:
--            options.pattern = ffi.new('char[]', to_bytes(pattern))
-+            # The returned pointer object has ownership on the allocated
-+            # memory. Make sure it is kept alive until git_describe_commit() or
-+            # git_describe_workdir() are called below.
-+            pattern_char = ffi.new('char[]', to_bytes(pattern))
-+            options.pattern = pattern_char
-         if only_follow_first_parent is not None:
-             options.only_follow_first_parent = only_follow_first_parent
-         if show_commit_oid_as_fallback is not None:
-diff --git a/setup.py b/setup.py
-index f4a9f8c..18d3eb0 100644
---- a/setup.py
-+++ b/setup.py
-@@ -203,8 +203,8 @@ def run(self):
-       long_description=long_description,
-       packages=['pygit2'],
-       package_data={'pygit2': ['decl.h']},
--      setup_requires=['cffi<1.10'],
--      install_requires=['cffi<1.10', 'six'],
-+      setup_requires=['cffi'],
-+      install_requires=['cffi', 'six'],
-       zip_safe=False,
-       cmdclass=cmdclass,
-       **extra_args)
diff --git a/dev-python/pygit2/pygit2-0.25.1.ebuild b/dev-python/pygit2/pygit2-0.25.1.ebuild
deleted file mode 100644 (file)
index 35a8f52..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 versionator
-
-DESCRIPTION="Python bindings for libgit2"
-HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.python.org/pypi/pygit2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
-       =dev-libs/libgit2-$(get_version_component_range 1-2)*
-       >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
-       "${FILESDIR}"/pygit2-0.25.1-cffi-1.10.patch
-)
-
-python_test() {
-       esetup.py test
-}