www-apache/mod_mono version bump. Added aspnet2 local USE flag. AutoHosting using...
authorJurek Bartuszek <jurek@gentoo.org>
Fri, 10 Nov 2006 01:55:58 +0000 (01:55 +0000)
committerJurek Bartuszek <jurek@gentoo.org>
Fri, 10 Nov 2006 01:55:58 +0000 (01:55 +0000)
  possible. Added some descriptive comments to the 1.1.17 config file.
Package-Manager: portage-2.1.1-r1

www-apache/mod_mono/ChangeLog
www-apache/mod_mono/files/1.1.17/70_mod_mono.conf
www-apache/mod_mono/files/digest-mod_mono-1.1.17-r1 [new file with mode: 0644]
www-apache/mod_mono/files/mono_auto_application_aspnet2.patch [new file with mode: 0644]
www-apache/mod_mono/mod_mono-1.1.17-r1.ebuild [new file with mode: 0644]

index 1f8dc784553d4eabb9e3bf4dfaad5d5994c0d8fe..90185fd24065de2a8a6f715d1c667e3fd94d3d66 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for www-apache/mod_mono
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_mono/ChangeLog,v 1.24 2006/10/27 13:57:30 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_mono/ChangeLog,v 1.25 2006/11/10 01:55:58 jurek Exp $
+
+*mod_mono-1.1.17-r1 (10 Nov 2006)
+
+  10 Nov 2006; Jurek Bartuszek <jurek@gentoo.org>
+  files/1.1.17/70_mod_mono.conf, +files/mono_auto_application_aspnet2.patch,
+  -mod_mono-1.1.17.ebuild, +mod_mono-1.1.17-r1.ebuild:
+  Added aspnet2 local USE flag. AutoHosting using mod-mono-server2 is now
+  possible. Added some descriptive comments to the 1.1.17 config file.
 
 *mod_mono-1.1.17 (27 Oct 2006)
 *mod_mono-1.1.13.5 (27 Oct 2006)
index 0106e7244a5bd3cc5d8588d9f487f2989f6a7eff..eff05b13d1fc821724e2da94bb72f67ad0672389 100644 (file)
@@ -6,14 +6,12 @@
        # /etc/init.d/mod-mono-server
        MonoRunXSP True
 
-       # Set this to Enabled if you want to enable AutoHosting
-       # See http://www.mono-project.com/AutoConfiguration for more info
-       MonoAutoApplication Disabled
+       # Set this to Enabled if you want to enable AutoHosting.
+       # See http://www.mono-project.com/AutoConfiguration for more info.
+       # Note that if you want your automatically hosted applications
+       # handled by ASP.NET 2.0 engine you have to enable the aspnet2 USE flag.
+       MonoAutoApplication Enabled
 
-       # If you want to host ASP.NET 2.0 applications, uncomment the line below
-       # Otherwise, leave it unchanged
-       #MonoServerPath /usr/lib/mono/2.0/mod-mono-server2.exe
-       
        <IfModule !mod_mono.c>
                LoadModule mono_module modules/mod_mono.so
        </IfModule>
                DirectoryIndex default.aspx
        </IfModule>
 
-### please also add "-D MONO_DEMO" in order to activate out-of-the-box mono demo
+### Please also add "-D MONO_DEMO" in order to activate out-of-the-box mono demo
 ###
+
+       # Note that the test application runs on a separate mod-mono-server
+       # instance named "testinst". Athought this is not mandatory, it shows how to
+       # distribute workload between multiple mod-mono-servers. For more info see:
+       # http://www.mono-project.com/Mod_mono
+
        <IfDefine MONO_DEMO>
                <IfModule mod_alias.c>
                        Alias /mono "/usr/lib/xsp/test"
                </IfModule>
 
-               AddMonoApplications default "/mono:/usr/lib/xsp/test"
+               # You might want to specify the version of mod-mono-server
+               # instance that will handle your application. The default
+               # value depends on whether the aspnet2 USE flag was set
+               # during compilation
+               #MonoServerPath testinst /usr/lib/mono/1.0/mod-mono-server.exe
+               #MonoServerPath testinst /usr/lib/mono/2.0/mod-mono-server2.exe
+               
+               AddMonoApplications testinst "/mono:/usr/lib/xsp/test"
 
                <Directory /usr/lib/xsp/test>
                        SetHandler mono
+                       MonoSetServerAlias testinst
 
                        <IfModule mod_access.c>
                                Order allow,deny
diff --git a/www-apache/mod_mono/files/digest-mod_mono-1.1.17-r1 b/www-apache/mod_mono/files/digest-mod_mono-1.1.17-r1
new file mode 100644 (file)
index 0000000..d0fbdc5
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 3f0408a350f6f55029b75f4332be171f mod_mono-1.1.17.tar.gz 334754
+RMD160 0e567ea06deaa7255b63dd835e4be9549e5c1e35 mod_mono-1.1.17.tar.gz 334754
+SHA256 92dc2703c2d675529698e779d3d60afcfb5842a784da0bb0ddf573c0757a1144 mod_mono-1.1.17.tar.gz 334754
diff --git a/www-apache/mod_mono/files/mono_auto_application_aspnet2.patch b/www-apache/mod_mono/files/mono_auto_application_aspnet2.patch
new file mode 100644 (file)
index 0000000..8ccc27a
--- /dev/null
@@ -0,0 +1,11 @@
+--- mod_mono-1.1.17-old/src/mod_mono.h 2006-08-30 17:05:42.000000000 +0200
++++ mod_mono-1.1.17/src/mod_mono.h     2006-11-10 01:11:22.000000000 +0100
+@@ -158,7 +158,7 @@
+ #define DIRECTORY_SEPARATOR   ":"
+ #endif
+-#define MODMONO_SERVER_PATH   MONO_PREFIX "/bin/mod-mono-server"
++#define MODMONO_SERVER_PATH   MONO_PREFIX "/bin/mod-mono-server2"
+ #define WAPIDIR                               "/tmp"
+ #define DOCUMENT_ROOT         NULL
+ #define APPCONFIG_FILE                NULL
diff --git a/www-apache/mod_mono/mod_mono-1.1.17-r1.ebuild b/www-apache/mod_mono/mod_mono-1.1.17-r1.ebuild
new file mode 100644 (file)
index 0000000..be06229
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_mono/mod_mono-1.1.17-r1.ebuild,v 1.1 2006/11/10 01:55:58 jurek Exp $
+
+inherit apache-module eutils
+
+DESCRIPTION="Apache module for Mono"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://go-mono.com/sources/${PN}/${P}.tar.gz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="apache2 debug aspnet2"
+DEPEND=">=dev-dotnet/xsp-1.1.17"
+
+RDEPEND="${DEPEND}"
+
+APACHE1_MOD_FILE="${S}/src/.libs/mod_mono.so"
+APACHE1_MOD_CONF="${PV}/70_mod_mono"
+APACHE1_MOD_DEFINE="MONO"
+
+APACHE2_MOD_FILE="${S}/src/.libs/mod_mono.so"
+APACHE2_MOD_CONF="${PV}/70_mod_mono"
+APACHE2_MOD_DEFINE="MONO"
+
+DOCFILES="AUTHORS ChangeLog COPYING INSTALL NEWS README"
+
+need_apache
+
+src_unpack()
+{
+       unpack ${A}
+       cd ${S}
+
+       use aspnet2 && epatch ${FILESDIR}/mono_auto_application_aspnet2.patch
+}
+
+src_compile() {
+       conf="$(use_enable debug) \
+                 --disable-dependency-tracking"
+       econf ${conf} || die "econf failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       mv src/.libs/mod_mono.so{.0.0.0,}
+       apache-module_src_install
+       doman man/mod_mono.8
+}
+
+pkg_postinst() {
+       apache-module_pkg_postinst
+
+       elog "To enable mod_mono, add \"-D MONO\" to your apache's"
+       elog "conf.d configuration file. Additionally, to view sample"
+       elog "ASP.NET applications, add \"-D MONO_DEMO\" too."
+       elog ""
+       elog "If you want mod_mono to handle AutoHosting requests using"
+       elog "ASP.NET 2.0 engine, enable the aspnet2 USE flag"
+}