app-i18n/nkf: update to EAPI 7
authorAkinori Hattori <hattya@gentoo.org>
Sat, 16 May 2020 13:49:44 +0000 (22:49 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 16 May 2020 14:47:41 +0000 (23:47 +0900)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-i18n/nkf/nkf-2.1.4.ebuild

index 25f4cbcc3d490d5a0be9b69fb231876452ee0816..6f616167fa751a0b4723e8027fd8bdf755358a4e 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="6"
+EAPI="7"
 PYTHON_COMPAT=( python3_6 )
 
 inherit distutils-r1 perl-module toolchain-funcs vcs-snapshot
@@ -19,6 +19,10 @@ SLOT="0"
 KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
 IUSE="perl python l10n_ja"
 
+src_unpack() {
+       use python && vcs-snapshot_src_unpack || default
+}
+
 src_prepare() {
        sed -i \
                -e "/^CFLAGS/{ s/-g -O2//; s/=/+=/; }" \