ktoblzcheck bump and removal of old stuff
authorHanno Boeck <hanno@gentoo.org>
Fri, 24 Nov 2006 20:35:09 +0000 (20:35 +0000)
committerHanno Boeck <hanno@gentoo.org>
Fri, 24 Nov 2006 20:35:09 +0000 (20:35 +0000)
Package-Manager: portage-2.1.2_rc2-r1

app-misc/ktoblzcheck/ChangeLog
app-misc/ktoblzcheck/files/digest-ktoblzcheck-1.12 [new file with mode: 0644]
app-misc/ktoblzcheck/ktoblzcheck-1.12.ebuild [new file with mode: 0644]

index c8100a8355684e57b5f0629ddd1dc9fb170e025e..1886621884b3d87a6c7b581951d30b786ac69a0e 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for app-misc/ktoblzcheck
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.44 2006/11/06 20:23:54 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.45 2006/11/24 20:35:09 hanno Exp $
+
+*ktoblzcheck-1.12 (24 Nov 2006)
+
+  24 Nov 2006; Hanno Boeck <hanno@gentoo.org> +ktoblzcheck-1.12.ebuild:
+  Version bump, python support.
 
   06 Nov 2006; Matti Bickel <mabi@gentoo.org> ktoblzcheck-1.11.ebuild:
   Stable on ppc (bug #149970)
diff --git a/app-misc/ktoblzcheck/files/digest-ktoblzcheck-1.12 b/app-misc/ktoblzcheck/files/digest-ktoblzcheck-1.12
new file mode 100644 (file)
index 0000000..7daa75c
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 1337e4b7831b71047433c84ace47ed22 ktoblzcheck-1.12.tar.gz 448027
+RMD160 162e93fd03fade0b91e9c12b2e65f30b86aa9dc3 ktoblzcheck-1.12.tar.gz 448027
+SHA256 3555419c594bcafda5fab52c7bfb77448e522f19a4ec1d6ac9cf8c9ae2767dd9 ktoblzcheck-1.12.tar.gz 448027
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.12.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.12.ebuild
new file mode 100644 (file)
index 0000000..283ba40
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-1.12.ebuild,v 1.1 2006/11/24 20:35:09 hanno Exp $
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ktoblzcheck/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="python"
+
+DEPEND="sys-apps/gawk
+       sys-apps/grep
+       sys-devel/libtool
+       python? ( dev-python/ctypes )"
+
+src_compile() {
+       econf `use_enable python` || die
+       emake || die
+}
+
+src_install() {
+       einstall BANKDATA_PATH="${D}/usr/share/ktoblzcheck" || die
+}