www-apps/cgit: Switch to git-r3
authorMichał Górny <mgorny@gentoo.org>
Sun, 15 Dec 2019 20:34:04 +0000 (21:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 15 Dec 2019 20:34:04 +0000 (21:34 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
www-apps/cgit/cgit-9999.ebuild

index a6df9326558dd66746f3a508fb5b7a808c2fe448..3633d01125ba75298d646b89b63828eb87bcce51 100644 (file)
@@ -1,11 +1,11 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
+EAPI=5
 
 WEBAPP_MANUAL_SLOT="yes"
 
-inherit webapp eutils multilib user toolchain-funcs git-2
+inherit webapp eutils multilib user toolchain-funcs git-r3
 
 [[ -z "${CGIT_CACHEDIR}" ]] && CGIT_CACHEDIR="/var/cache/${PN}/"
 
@@ -41,9 +41,6 @@ pkg_setup() {
 }
 
 src_prepare() {
-       git submodule init || die
-       git submodule update || die
-
        echo "prefix = ${EPREFIX}/usr" >> cgit.conf
        echo "libdir = ${EPREFIX}/usr/$(get_libdir)" >> cgit.conf
        echo "CGIT_SCRIPT_PATH = ${MY_CGIBINDIR}" >> cgit.conf