0.11.2 version bump, remove old 0.10.2 version.
authorMarcelo Góes <vanquirius@gentoo.org>
Sat, 2 Dec 2006 15:33:25 +0000 (15:33 +0000)
committerMarcelo Góes <vanquirius@gentoo.org>
Sat, 2 Dec 2006 15:33:25 +0000 (15:33 +0000)
Package-Manager: portage-2.1.1-r2

net-analyzer/pmacct/ChangeLog
net-analyzer/pmacct/files/digest-pmacct-0.11.2 [new file with mode: 0644]
net-analyzer/pmacct/pmacct-0.11.2.ebuild [new file with mode: 0644]

index 4e5c30a9c060f96ab3fa7ffc7979d84e2c321ad1..b94d9e530bde39220b9c37d8473608131d9317ef 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-analyzer/pmacct
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.43 2006/11/23 19:52:40 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.44 2006/12/02 15:33:25 vanquirius Exp $
+
+*pmacct-0.11.2 (02 Dec 2006)
+
+  02 Dec 2006; Marcelo Goes <vanquirius@gentoo.org> -pmacct-0.10.2.ebuild,
+  +pmacct-0.11.2.ebuild:
+  0.11.2 version bump, remove old 0.10.2 version.
 
   23 Nov 2006; Francesco Riosa <vivo@gentoo.org> pmacct-0.9.5.ebuild,
   pmacct-0.10.2.ebuild, pmacct-0.10.3.ebuild:
diff --git a/net-analyzer/pmacct/files/digest-pmacct-0.11.2 b/net-analyzer/pmacct/files/digest-pmacct-0.11.2
new file mode 100644 (file)
index 0000000..d1b51d2
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 90a16305fce4ebcfdce255cc1b256b1f pmacct-0.11.2.tar.gz 411711
+RMD160 99bead4c09b060854bff72b18ac7150097e78643 pmacct-0.11.2.tar.gz 411711
+SHA256 6d8346944c987a2ec9e6b29cbbc2a886007a2535b9d506051ef6afe96faac625 pmacct-0.11.2.tar.gz 411711
diff --git a/net-analyzer/pmacct/pmacct-0.11.2.ebuild b/net-analyzer/pmacct/pmacct-0.11.2.ebuild
new file mode 100644 (file)
index 0000000..2fdb7c6
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.11.2.ebuild,v 1.1 2006/12/02 15:33:25 vanquirius Exp $
+
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="64bit debug ipv6 mmap mysql postgres"
+
+RDEPEND="net-libs/libpcap
+       mysql? ( virtual/mysql )
+       postgres? ( dev-db/postgresql )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+}
+
+src_compile() {
+       econf \
+               $(use_enable mysql) \
+               $(use_enable postgres pgsql) \
+               $(use_enable mmap) \
+               $(use_enable ipv6) \
+               $(use_enable debug) \
+               $(use_enable 64bit) \
+               || die "econf failed"
+
+       emake || die "emake failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "make install failed"
+       dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
+               docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+       for dirname in examples sql; do
+               docinto ${dirname}
+               dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+       done
+
+       newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
+       newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+       insinto /etc
+       newins "${S}"/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
+               die "newins failed"
+}