dev-libs/opensc: Add elibtoolize to fix cross compiling for arm/arm64
authorJohn L Chen <zuan@chromium.org>
Tue, 21 Apr 2020 20:02:41 +0000 (04:02 +0800)
committerMikle Kolyada <zlogene@gentoo.org>
Wed, 22 Apr 2020 08:31:47 +0000 (11:31 +0300)
opensc fails to cross compile for arm/arm64 target because libtool
adds host /usr/lib64 to -L during make install when the libraries are
relinked.

Adding elibtoolize in src_prepare() applies the "cross" patch that
fixes this.

Closes: https://bugs.gentoo.org/718790
Signed-off-by: John L Chen <zuan@chromium.org>
Closes: https://github.com/gentoo/gentoo/pull/15460
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-libs/opensc/opensc-0.20.0.ebuild

index b5a3fd35a32dbf3cfa5e54b0291737dec2cf69fb..d32490c9e604dba051164144a836d23a0793dbad 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit bash-completion-r1
+inherit bash-completion-r1 libtool
 
 DESCRIPTION="Libraries and applications to access smartcards"
 HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
@@ -36,6 +36,11 @@ REQUIRED_USE="
        ctapi? ( !pcsc-lite !openct )
        || ( pcsc-lite openct ctapi )"
 
+src_prepare() {
+       default
+       elibtoolize
+}
+
 src_configure() {
        econf \
                --with-completiondir="$(get_bashcompdir)" \