dev-python/pytest-xprocess: Remove old
authorMichał Górny <mgorny@gentoo.org>
Fri, 17 Apr 2020 05:43:17 +0000 (07:43 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 17 Apr 2020 05:43:17 +0000 (07:43 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-xprocess/Manifest
dev-python/pytest-xprocess/files/pytest-xprocess-0.12.1-pytest-28.patch [deleted file]
dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r2.ebuild [deleted file]

index 6958ed0da9efd9be3d0549310b389b0b18ec2e04..746c2142ff6b0da6dd97a4235e09e2a803a40419 100644 (file)
@@ -1,2 +1 @@
-DIST pytest-xprocess-0.12.1.tar.gz 12078 BLAKE2B 30c3c2b41e79b79c5a18911c325ff273b80c45f29d269b96c4085c0c78a6897b2064eb1d2e83f9c061c4663d2f52d88230d9e87ea2ba4d114c6e04f42aa50a5e SHA512 fda868a12a056070afd5838c4bc466b4906a7138f685d4a0e6e0adbd975e5a1a2b9b37b8de36a45fb700e02ca14ae219cfe29c467f8d03e55d2a375a7efc9927
 DIST pytest-xprocess-0.13.1.tar.gz 10273 BLAKE2B 0c2a8bdf5e31543b32ada50f2bb5e1a09b45de820064807bf41321638d11d6b6fea28fd2a8c795e7bc6f7ac7370a3e78988e8aee318fad9df194fd3b06cce7cd SHA512 e0ab9e13d7f90ffca1bb3646e5789582806519ff5e665e13ed0db00896d799a7828b39e7657e947783d15ec1a961b33c1c981e39069dd298bf352826dbdc496f
diff --git a/dev-python/pytest-xprocess/files/pytest-xprocess-0.12.1-pytest-28.patch b/dev-python/pytest-xprocess/files/pytest-xprocess-0.12.1-pytest-28.patch
deleted file mode 100644 (file)
index 45d3b24..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-From 4b5de795b492b5beb15385b20fe289851c1b2570 Mon Sep 17 00:00:00 2001
-From: Bruno Oliveira <nicoddemus@gmail.com>
-Date: Wed, 7 Jun 2017 09:55:28 -0300
-Subject: [PATCH] Add py35 and py36 to CI and drop support for pytest<2.8
-
-Also drop requirement on pytest_cache
----
- pytest_xprocess.py | 3 +--
- setup.py           | 2 +-
- 2 files changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/pytest_xprocess.py b/pytest_xprocess.py
-index e8d731c..c4edbdd 100644
---- a/pytest_xprocess.py
-+++ b/pytest_xprocess.py
-@@ -18,8 +18,7 @@ def pytest_addoption(parser):
- def getrootdir(config):
--    from pytest_cache import getrootdir
--    return getrootdir(config, ".xprocess").ensure(dir=1)
-+    return config.rootdir.join(".xprocess").ensure(dir=1)
- def pytest_cmdline_main(config):
-diff --git a/setup.py b/setup.py
-index 1992785..b3dd88c 100755
---- a/setup.py
-+++ b/setup.py
-@@ -12,5 +12,5 @@ if __name__ == "__main__":
-         url='https://github.com/pytest-dev/pytest-xprocess/',
-         py_modules=['pytest_xprocess', 'xprocess'],
-         entry_points={'pytest11': ['xprocess = pytest_xprocess']},
--        install_requires=['pytest-cache', 'pytest>=2.3.5', 'psutil'],
-+        install_requires=['pytest>=2.8', 'psutil'],
-     )
--- 
-2.24.0
-
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r2.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r2.ebuild
deleted file mode 100644 (file)
index e4f4528..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage external processes across test runs"
-HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
-       dev-python/pytest[${PYTHON_USEDEP}]
-       dev-python/psutil[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
-       "${FILESDIR}"/pytest-xprocess-0.12.1-pytest-28.patch
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
-       # Upstream's package mistakenly includes __pycache__ directory that make
-       # tests fail.
-       rm -r example/__pycache__ || die
-       distutils-r1_src_prepare
-}